summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-02-03 23:51:29 +0000
committerHans-Nikolai Viessmann2018-02-03 23:51:29 +0000
commit73b3ba193d5662c716627d15ae58c05b72db6ae1 (patch)
tree205cdaaa4098a83d14c14c8a0af1741ac26ed770
downloadaur-73b3ba193d5662c716627d15ae58c05b72db6ae1.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aac20dcce747
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = easybuild-framework-git
+ pkgdesc = A software build and installation framework for HPC systems (development)
+ pkgver = 3.5.1.r14.g5774d360d
+ pkgrel = 2
+ url = https://github.com/easybuilders
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-vsc-base
+ depends = env-modules-tcl
+ optdepends = lmod: another module management tool
+ optdepends = fpm: Generate packages of your modules to be installed later
+ optdepends = easybuild-easyconfigs-git: collection of build parameters
+ optdepends = easybuild-easyblocks-git: collection of module recipes
+ source = git+https://github.com/easybuilders/easybuild-framework.git#branch=develop
+ md5sums = SKIP
+
+pkgname = easybuild-framework-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38c345273ccd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
+pkgname='easybuild-framework-git'
+pkgver=3.5.1.r14.g5774d360d
+pkgrel=2
+pkgdesc="A software build and installation framework for HPC systems (development)"
+arch=('any')
+group='easybuild-git'
+url="https://github.com/easybuilders"
+license=('GPL')
+depends=('python2' 'python2-vsc-base' 'env-modules-tcl')
+optdepends=('lmod: another module management tool'
+ 'fpm: Generate packages of your modules to be installed later'
+ 'easybuild-easyconfigs-git: collection of build parameters'
+ 'easybuild-easyblocks-git: collection of module recipes')
+makedepends=('git' 'python2-setuptools')
+source=('git+https://github.com/easybuilders/easybuild-framework.git#branch=develop')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/easybuild-framework"
+
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/.*v\(.*\)$/\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/easybuild-framework"
+ python2 setup.py install --root "$pkgdir"
+}