summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-02-03 23:59:30 +0000
committerHans-Nikolai Viessmann2018-02-03 23:59:30 +0000
commit7a874aa02dffa8e72bae49a418ea3312a34dec34 (patch)
tree24231c853c1de538b8314a8cc7bf72ffb28b4913
parent73b3ba193d5662c716627d15ae58c05b72db6ae1 (diff)
downloadaur-7a874aa02dffa8e72bae49a418ea3312a34dec34.tar.gz
minor fixes
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aac20dcce747..45f2851a9f5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = easybuild-framework-git
pkgdesc = A software build and installation framework for HPC systems (development)
pkgver = 3.5.1.r14.g5774d360d
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/easybuilders
arch = any
+ groups = easybuild-git
license = GPL
makedepends = git
makedepends = python2-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index 38c345273ccd..5ca719dae8e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
pkgname='easybuild-framework-git'
pkgver=3.5.1.r14.g5774d360d
-pkgrel=2
+pkgrel=3
pkgdesc="A software build and installation framework for HPC systems (development)"
arch=('any')
-group='easybuild-git'
+groups=('easybuild-git')
url="https://github.com/easybuilders"
license=('GPL')
depends=('python2' 'python2-vsc-base' 'env-modules-tcl')
optdepends=('lmod: another module management tool'
'fpm: Generate packages of your modules to be installed later'
- 'easybuild-easyconfigs-git: collection of build parameters'
+ 'easybuild-easyconfigs-git: collection of build parameters'
'easybuild-easyblocks-git: collection of module recipes')
makedepends=('git' 'python2-setuptools')
source=('git+https://github.com/easybuilders/easybuild-framework.git#branch=develop')
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/easybuild-framework"
-
- printf "%s" "$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/.*v\(.*\)$/\1/;s/-/./g')"
+ cd "$srcdir/easybuild-framework"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/.*v\(.*\)$/\1/;s/-/./g')"
}
package() {
- cd "$srcdir/easybuild-framework"
+ cd "$srcdir/easybuild-framework"
python2 setup.py install --root "$pkgdir"
}