summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormalacology2021-05-05 06:07:46 +0800
committermalacology2021-05-05 06:07:46 +0800
commitc2e47c258b697e36748476b75c9a408384fb3ddc (patch)
tree937e5bddcce2e6a503734e3a7686c868cd5b8ac9
downloadaur-c2e47c258b697e36748476b75c9a408384fb3ddc.tar.gz
new
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD70
-rw-r--r--easycodeml.desktop18
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a1ef3079647
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = easycodeml
+ pkgdesc = A visual tool for analysis of selection using CodeML
+ pkgver = 1.21
+ pkgrel = 1
+ url = https://github.com/BioEasy/EasyCodeML
+ arch = x86_64
+ license = unknow
+ depends = jre-openjdk-headless
+ depends = jre-openjdk
+ depends = jdk-openjdk
+ depends = openjdk-doc
+ depends = openjdk-src
+ source = https://github.com/starsareintherose/easycodeml/releases/download/1.21/EasyCodeML.zip
+ sha256sums = SKIP
+
+pkgname = easycodeml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7434d129e3fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Malacology <guoyizhang at malacology dot com>
+# Contributor: Malacology <guoyizhang at malacology dot com>
+
+pkgname=easycodeml
+pkgver=1.21
+pkgrel=1
+pkgdesc="A visual tool for analysis of selection using CodeML"
+arch=('x86_64')
+url="https://github.com/BioEasy/EasyCodeML"
+license=('unknow')
+source=("https://github.com/starsareintherose/easycodeml/releases/download/${pkgver}/EasyCodeML.zip")
+sha256sums=('SKIP')
+depends=(
+ 'jre-openjdk-headless'
+ 'jre-openjdk'
+ 'jdk-openjdk'
+ 'openjdk-doc'
+ 'openjdk-src'
+)
+package() {
+ mkdir "${pkgdir}/usr"
+ mkdir "${pkgdir}/usr/share"
+ mkdir "${pkgdir}/usr/share/applications"
+ mkdir "${pkgdir}/usr/share/EasyCodeML"
+ mkdir "${pkgdir}/usr/share/EasyCodeML/Custom"
+ mkdir "${pkgdir}/usr/share/EasyCodeML/Custom/dat"
+ mkdir "${pkgdir}/usr/share/EasyCodeML/CodeMLSrc"
+ mkdir "${pkgdir}/usr/share/EasyCodeML/CodeMLSrc/Linux"
+
+
+ install -m 755 ${srcdir}/EasyCodeML/EasyCodeML.jar ${pkgdir}/usr/share/EasyCodeML/EasyCodeML.jar
+ install -m 755 ${srcdir}/EasyCodeML/Quick_Guide.pdf ${pkgdir}/usr/share/EasyCodeML/Quick_Guide.pdf
+ install -m 755 ${srcdir}/EasyCodeML/README.md ${pkgdir}/usr/share/EasyCodeML/README.md
+ install -m 755 "${srcdir}/EasyCodeML/Version History.txt" "${pkgdir}/usr/share/EasyCodeML/Version History.txt"
+ install -m 755 ${srcdir}/EasyCodeML/Citation.ris ${pkgdir}/usr/share/EasyCodeML/Citation.ris
+
+ install -m 755 ${srcdir}/EasyCodeML/CodeMLSrc/chi2.c ${pkgdir}/usr/share/EasyCodeML/CodeMLSrc/chi2.c
+ install -m 755 ${srcdir}/EasyCodeML/CodeMLSrc/chi2.c ${pkgdir}/usr/share/EasyCodeML/CodeMLSrc/chi2.c
+ install -m 755 "${srcdir}/EasyCodeML/CodeMLSrc/Compile Commands for Mac or Linux" "${pkgdir}/usr/share/EasyCodeML/CodeMLSrc/Compile Commands for Mac or Linux"
+ install -m 755 ${srcdir}/EasyCodeML/CodeMLSrc/paml.h ${pkgdir}/usr/share/EasyCodeML/CodeMLSrc/paml.h
+ install -m 755 ${srcdir}/EasyCodeML/CodeMLSrc/tools.c ${pkgdir}/usr/share/EasyCodeML/CodeMLSrc/tools.c
+ install -m 755 ${srcdir}/EasyCodeML/CodeMLSrc/treespace.c ${pkgdir}/usr/share/EasyCodeML/CodeMLSrc/treespace.c
+ install -m 755 ${srcdir}/EasyCodeML/CodeMLSrc/treesub.c ${pkgdir}/usr/share/EasyCodeML/CodeMLSrc/treesub.c
+ install -m 755 ${srcdir}/EasyCodeML/CodeMLSrc/Linux/chi2.exe ${pkgdir}/usr/share/EasyCodeML/CodeMLSrc/Linux/chi2.exe
+ install -m 755 ${srcdir}/EasyCodeML/CodeMLSrc/Linux/codeml.exe ${pkgdir}/usr/share/EasyCodeML/CodeMLSrc/Linux/codeml.exe
+
+ install -m 755 ${srcdir}/EasyCodeML/Custom/codeml.ctl ${pkgdir}/usr/share/EasyCodeML/Custom/codeml.ctl
+ install -m 755 ${srcdir}/EasyCodeML/Custom/default.ctl ${pkgdir}/usr/share/EasyCodeML/Custom/default.ctl
+
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/cpREV10.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/cpREV10.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/cpREV64.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/cpREV64.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/dayhoff.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/dayhoff.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/dayhoff-dcmut.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/dayhoff-dcmut.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/g1974a.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/g1974a.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/g1974c.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/g1974c.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/g1974p.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/g1974p.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/g1974v.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/g1974v.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/grantham.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/grantham.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/jones.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/jones.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/jones-dcmut.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/jones-dcmut.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/lg.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/lg.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/miyata.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/miyata.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/mtArt.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/mtArt.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/mtmam.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/mtmam.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/mtREV24.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/mtREV24.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/MtZoa.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/MtZoa.dat
+ install -m 755 ${srcdir}/EasyCodeML/Custom/dat/wag.dat ${pkgdir}/usr/share/EasyCodeML/Custom/dat/wag.dat
+
+ cp ~/.cache/yay/easycodeml/easycodeml.desktop ${pkgdir}/usr/share/applications
+}
diff --git a/easycodeml.desktop b/easycodeml.desktop
new file mode 100644
index 000000000000..8ff521c68f13
--- /dev/null
+++ b/easycodeml.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Categories=
+Encoding=UTF-8
+Exec=java -jar /usr/share/EasyCodeML/EasyCodeML.jar
+GenericName=
+GenericName[zh]=
+Icon=java15-openjdk
+MimeType=
+Name=EasyCodeML
+Name[zh]=EasyCodeML
+ServiceTypes=
+SwallowExec=
+SwallowTitle=
+Terminal=false
+TerminalOptions=
+Type=Application
+X-KDE-SubstituteUID=false
+X-KDE-Username=root%