summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2022-08-18 12:45:03 +0000
committerBioArchLinuxBot2022-08-18 12:45:03 +0000
commitfeda226a1e86f6f9a4d6f942a2cbb29271eace38 (patch)
treea19863f95c5bca1358ad660bdd530227a54fcc56
parente1235935e1dd03823841ccee385e8ebff0c53176 (diff)
downloadaur-feda226a1e86f6f9a4d6f942a2cbb29271eace38.tar.gz
[lilac] updated to 1.4-3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cab6c313877..5f6112c1ddf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,24 @@
pkgbase = easycodeml
pkgdesc = A visual tool for analysis of selection using CodeML. https://doi.org/10.1002/ece3.5015
pkgver = 1.4
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/BioEasy/EasyCodeML
arch = x86_64
license = LGPL3
depends = java-runtime
+ depends = paml
source = https://raw.githubusercontent.com/BioEasy/EasyCodeML/master/EasyCodeML.jar
+ source = https://raw.githubusercontent.com/BioEasy/EasyCodeML/master/Custom/codeml.ctl
+ source = https://raw.githubusercontent.com/BioEasy/EasyCodeML/master/Custom/default.ctl
+ source = https://github.com/BioEasy/EasyCodeML/raw/master/Preset/chi2.exe
+ source = https://github.com/BioEasy/EasyCodeML/raw/master/Preset/codeml.exe
source = easycodeml.desktop
source = EasyCodeML.png
sha256sums = 16eef77a21be47ac2b2cf2e04ded75dc76546a71e0ca227aa21e0418ec8caf36
+ sha256sums = 2a369a9497cf9435322dc2dad32787f0178685d483ed12aa407e7702b68071a1
+ sha256sums = b665482ad39736725dbf8b21081ddb9761c7e35c68fc93860889bd52b2429756
+ sha256sums = 3f6e8b9fcfb161d7e920bf3958b6820ad2a8cdb666b3faa4cf538d14e3ba0428
+ sha256sums = f5884da79e69c972570225a2f2562e43c47f2935b4dd858aae4789440b691adb
sha256sums = e20af3e0e14be4f95d634bf5c34cb35dc37edfada7d97f9c0e9dd10afa7cbf6f
sha256sums = 5393db9477bd071511788ea6255c49005274b4aebe792a7631eaa296ada14987
diff --git a/PKGBUILD b/PKGBUILD
index 98862bd9e8c3..e4a6d9f76b92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,38 @@
pkgname=easycodeml
pkgver=1.4
-pkgrel=1
+pkgrel=3
pkgdesc="A visual tool for analysis of selection using CodeML. https://doi.org/10.1002/ece3.5015"
arch=('x86_64')
url="https://github.com/BioEasy/EasyCodeML"
license=('LGPL3')
-source=("https://raw.githubusercontent.com/BioEasy/EasyCodeML/master/EasyCodeML.jar" "easycodeml.desktop" "EasyCodeML.png")
+source=("https://raw.githubusercontent.com/BioEasy/EasyCodeML/master/EasyCodeML.jar"
+ "https://raw.githubusercontent.com/BioEasy/EasyCodeML/master/Custom/codeml.ctl"
+ "https://raw.githubusercontent.com/BioEasy/EasyCodeML/master/Custom/default.ctl"
+ "https://github.com/BioEasy/EasyCodeML/raw/master/Preset/chi2.exe"
+ "https://github.com/BioEasy/EasyCodeML/raw/master/Preset/codeml.exe"
+ "easycodeml.desktop"
+ "EasyCodeML.png")
sha256sums=('16eef77a21be47ac2b2cf2e04ded75dc76546a71e0ca227aa21e0418ec8caf36'
+ '2a369a9497cf9435322dc2dad32787f0178685d483ed12aa407e7702b68071a1'
+ 'b665482ad39736725dbf8b21081ddb9761c7e35c68fc93860889bd52b2429756'
+ '3f6e8b9fcfb161d7e920bf3958b6820ad2a8cdb666b3faa4cf538d14e3ba0428'
+ 'f5884da79e69c972570225a2f2562e43c47f2935b4dd858aae4789440b691adb'
'e20af3e0e14be4f95d634bf5c34cb35dc37edfada7d97f9c0e9dd10afa7cbf6f'
'5393db9477bd071511788ea6255c49005274b4aebe792a7631eaa296ada14987')
depends=(
'java-runtime'
+ 'paml'
)
package() {
- install -dm755 "$pkgdir"/usr/share/{EasyCodeML,applications}
+ install -dm755 "$pkgdir"/usr/share/{EasyCodeML/{Custom,Preset,CodeMLSrc/Linux},applications}
install -Dm 755 "$srcdir"/EasyCodeML.jar "$pkgdir"/usr/share/EasyCodeML
+ install -Dm 755 $srcdir/*.ctl "$pkgdir"/usr/share/EasyCodeML/Custom/
+for bin in chi2 codeml
+do
+ ln -s /usr/bin/$bin $pkgdir/usr/share/EasyCodeML/CodeMLSrc/Linux/$bin.exe
+ install -Dm 777 $srcdir/$bin.exe $pkgdir/usr/share/EasyCodeML/Preset/$bin.exe
+done
install -m 755 ${srcdir}/EasyCodeML.png ${pkgdir}/usr/share/EasyCodeML/EasyCodeML.png
install -m 755 ${srcdir}/easycodeml.desktop ${pkgdir}/usr/share/applications/easycodeml.desktop
}