summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenri2019-04-06 19:19:07 +0200
committerHenri2019-04-06 19:19:07 +0200
commitaa6a7e4e626b3e8549d6a0ce4fcc84c19e2c3461 (patch)
treeaa088d71fc6b4a254b10c96d5dfdf4fcd52d4471
downloadaur-aa6a7e4e626b3e8549d6a0ce4fcc84c19e2c3461.tar.gz
initial PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f190928f088
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = easyeda
+ pkgdesc = EasyEDA Desktop Client, A Simple and Powerful Electronic Circuit Design Tool
+ pkgver = 2.0.0
+ pkgrel = 0
+ url = https://easyeda.com/page/download
+ arch = x86_64
+ license = custom
+ options = !strip
+ source = https://image.easyeda.com/files/easyeda-client-linux-x64.zip
+ sha256sums = SKIP
+
+pkgname = easyeda
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c3b078288ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+
+# Maintainer: Henri van de Munt <(firstname) @ gmail.com>
+
+pkgname=easyeda
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="EasyEDA Desktop Client, A Simple and Powerful Electronic Circuit Design Tool"
+arch=('x86_64')
+license=(custom)
+depends=()
+url="https://easyeda.com/page/download"
+options=('!strip')
+
+source=(https://image.easyeda.com/files/easyeda-client-linux-x64.zip)
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}"
+
+ install -d -m755 "${pkgdir}/opt/${pkgname}"
+
+ unzip -qqd ${pkgdir}/opt/${pkgname} easyeda-linux-x64.zip
+
+ install -d -m755 "${pkgdir}/usr/share/applications"
+
+cat <<EOF > "${pkgdir}/usr/share/applications/easyeda-${pkgver}.desktop"
+[Desktop Entry]
+Categories=Development;Electronics;
+Comment=A Simple and Powerful Electronic Circuit Design Tool
+Exec=/opt/easyeda/easyeda %f
+Terminal=false
+Keywords=PCB;EasyEDA;
+GenericName=EasyEDA
+Icon=/opt/easyeda/icon/128x128/easyeda.png
+Name=EasyEDA ${pkgver}
+Type=Application
+Name[en_US]=EasyEDA
+EOF
+
+}