summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2021-11-24 13:14:59 +0800
committeryjun2021-11-24 13:14:59 +0800
commitbb588a70bc3a01875dc77be5f8f90271a76d04a9 (patch)
treeaf339610ee9c82f6e1601cfeadd06035877c5f64
parentd220486aebb79bb5a47de1ed90ae87353f012c67 (diff)
downloadaur-bb588a70bc3a01875dc77be5f8f90271a76d04a9.tar.gz
pkgbuild: update source url
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD8
-rw-r--r--easyeda-router.sh2
4 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40e11d19d697..fc91a47bbef8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = easyeda-router
pkgdesc = LCEDA/EasyEDA local auto router server for Linux.
pkgver = 0.8.11
- pkgrel = 2
+ pkgrel = 3
url = https://docs.easyeda.com/en/PCB/Route/index.html#Local-Auto-Router
arch = x86_64
license = unknown
depends = jre8-openjdk-headless
- source = easyeda-router-0.8.11.zip::https://image.easyeda.com/files/EasyEDA-Router-v0.8.11.zip
+ source = easyeda-router-0.8.11.zip::https://image.easyeda.com/files/easyeda-router-linux-x64-v0.8.11.zip
source = easyeda-router.sh
source = easyeda-router.service
sha256sums = c7d5e36f60e9ff47a2775cdd922151173012d45f44bc843afeed80d1fb0a7616
- sha256sums = 1868c56d03b0ccd07d30b8e3756bf7550209092d2050c322c63860b9c8bf7ba5
+ sha256sums = 0b08eca8fc84a2b5ec3fc34c0cbcd37fd22cd9d2687214e298c82486bd7b9c0a
sha256sums = 35e5e4a2b5b6ba80ce9d8f807e3ddcabe1020fe77600a4de6b72f74f8a4c0a53
pkgname = easyeda-router
diff --git a/.gitignore b/.gitignore
index 9efb91101013..c46d30478f43 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+*.zst
pkg/
src/
-*.zip \ No newline at end of file
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 2762e819aef6..73f09928d939 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
pkgname=easyeda-router
pkgver=0.8.11
-pkgrel=2
+pkgrel=3
pkgdesc="LCEDA/EasyEDA local auto router server for Linux."
arch=('x86_64')
url="https://docs.easyeda.com/en/PCB/Route/index.html#Local-Auto-Router"
#url="https://docs.easyeda.com/cn/PCB/Route/index.html#%E6%9C%AC%E5%9C%B0%E8%87%AA%E5%8A%A8%E5%B8%83%E7%BA%BF"
license=('unknown')
depends=('jre8-openjdk-headless')
-source=(${pkgname}-${pkgver}.zip::"https://image.easyeda.com/files/EasyEDA-Router-v${pkgver}.zip")
-# source=(${pkgname}-${pkgver}.zip::"https://image.lceda.cn/files/EasyEDA-Router-latest.zip")
+source=(${pkgname}-${pkgver}.zip::"https://image.easyeda.com/files/easyeda-router-linux-x64-v${pkgver}.zip")
+# source=(${pkgname}-${pkgver}.zip::"https://image.lceda.cn/files/easyeda-router-linux-x64-v${pkgver}.zip")
source+=("${pkgname}.sh"
"${pkgname}.service")
sha256sums=('c7d5e36f60e9ff47a2775cdd922151173012d45f44bc843afeed80d1fb0a7616'
- '1868c56d03b0ccd07d30b8e3756bf7550209092d2050c322c63860b9c8bf7ba5'
+ '0b08eca8fc84a2b5ec3fc34c0cbcd37fd22cd9d2687214e298c82486bd7b9c0a'
'35e5e4a2b5b6ba80ce9d8f807e3ddcabe1020fe77600a4de6b72f74f8a4c0a53')
_install() {
diff --git a/easyeda-router.sh b/easyeda-router.sh
index a58f1f19407d..9bf81955fa3f 100644
--- a/easyeda-router.sh
+++ b/easyeda-router.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-exec /usr/bin/java -Dcom.easyeda.env=local -jar '/usr/share/java/easyeda-router/bin/bootstrap.jar' \ No newline at end of file
+exec /usr/lib/jvm/java-8-openjdk/jre/bin/java -Dcom.easyeda.env=local -jar '/usr/share/java/easyeda-router/bin/bootstrap.jar'