summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2024-04-16 20:46:15 +0200
committerGianluca Boiano2024-04-16 20:46:15 +0200
commit5862ef3ec95fa933bd876b83d2baf942943225da (patch)
tree56a2528ed1803143f39f7eb972e788d368d38b6b
parent9514aa5f908897adfa08b52377cc7031689ac4df (diff)
downloadaur-5862ef3ec95fa933bd876b83d2baf942943225da.tar.gz
easyeffects-git: update
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c31978ffa6d4..0cdd5919b146 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = easyeffects-git
pkgdesc = Audio Effects for Pipewire applications
- pkgver = 7.0.4.r132.g31e41d04
+ pkgver = 7.1.6.r145.ge225bd27a
pkgrel = 1
url = https://github.com/wwmm/easyeffects
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = easyeffects-git
arch = armv6h
arch = armv7h
arch = aarch64
- license = GPL3
+ license = GPL-3.0-only
makedepends = appstream-glib
makedepends = itstool
makedepends = meson
@@ -20,6 +20,7 @@ pkgbase = easyeffects-git
depends = libfmt.so
depends = gsl
depends = gtk4
+ depends = ladspa
depends = libadwaita-1.so
depends = libbs2b.so
depends = libebur128
diff --git a/PKGBUILD b/PKGBUILD
index d248028ebabe..610e79585d1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
# Contributor: Wellington <wellingtonwallace@gmail.com>
pkgname=easyeffects-git
-pkgver=7.0.4.r132.g31e41d04
+pkgver=7.1.6.r145.ge225bd27a
pkgrel=1
pkgdesc='Audio Effects for Pipewire applications'
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url='https://github.com/wwmm/easyeffects'
-license=('GPL3')
-depends=('fftw' 'libfmt.so' 'gsl' 'gtk4' 'libadwaita-1.so'
+license=('GPL-3.0-only')
+depends=('fftw' 'libfmt.so' 'gsl' 'gtk4' 'ladspa' 'libadwaita-1.so'
'libbs2b.so' 'libebur128' 'libsamplerate.so'
'libsigc-3.0.so' 'libsndfile.so' 'liblilv-0.so'
'pipewire' 'rnnoise' 'soundtouch'
@@ -35,9 +35,9 @@ pkgver() {
build() {
arch-meson "${pkgname%%-git}" build
- meson compile -C build
+ ninja -C build
}
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ DESTDIR="${pkgdir}" ninja install -C build
}