summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Walenciak2016-11-22 18:40:11 +0100
committerMichał Walenciak2016-11-22 18:40:11 +0100
commitecda1c88b98958f474d425b496c36533c324a5f5 (patch)
tree2c7b239fa9924e68b215871f4e60fc10308d86f6
downloadaur-ecda1c88b98958f474d425b496c36533c324a5f5.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD48
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d6df57e4e95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = easyexif-git
+ pkgdesc = Tiny ISO-compliant C++ EXIF parsing library, third-party dependency free.
+ pkgver = r34.a68a2cc
+ pkgrel = 1
+ url = https://github.com/mayanklahiri/easyexif
+ arch = i686
+ arch = x86_64
+ license = BSD-2-Clause
+ source = easyexif::git+https://github.com/mayanklahiri/easyexif.git
+ md5sums = SKIP
+
+pkgname = easyexif-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e114042366e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Michał Walenciak <kicer86@gmail.com>
+pkgname=easyexif-git
+pkgver=r34.a68a2cc
+pkgrel=1
+pkgdesc="Tiny ISO-compliant C++ EXIF parsing library, third-party dependency free."
+arch=('i686' 'x86_64')
+url="https://github.com/mayanklahiri/easyexif"
+license=('BSD-2-Clause')
+groups=()
+depends=()
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("easyexif::git+https://github.com/mayanklahiri/easyexif.git")
+noextract=()
+md5sums=('SKIP')
+
+build()
+{
+ cd easyexif
+
+ sed -i -e "s/^\(CXXFLAGS.*\)/\1 -fPIC/" Makefile
+ make
+ ar rcs libeasyexif.a exif.o
+}
+
+package()
+{
+ cd easyexif
+
+ mkdir -p $pkgdir/usr/lib
+ cp libeasyexif.a $pkgdir/usr/lib
+
+ mkdir -p $pkgdir/usr/include/easyexif
+ cp exif.h $pkgdir/usr/include/easyexif/
+}
+
+pkgver()
+{
+ cd easyexif
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}