summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMadPhysicist2016-12-30 01:05:43 -0500
committerMadPhysicist2016-12-30 01:05:43 -0500
commit0160afd5f0ac337c9485a56610b394c27e56faff (patch)
tree57f2f31fc0968d4011f2a05ed089215745908785
parent2115c18ee06d82e539ebcfa2536be2031ba693c3 (diff)
downloadaur-0160afd5f0ac337c9485a56610b394c27e56faff.tar.gz
Updated to version 9.88
Package maintainer made the distribution release file more AUR friendly: https://github.com/easylogging/easyloggingpp/issues/407
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8382710faecc..bd89e5b6761d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Tue Sep 13 04:45:48 UTC 2016
+# Fri Dec 30 06:04:26 UTC 2016
pkgbase = easyloggingpp
pkgdesc = Robust, thread-safe lightweight single header only C++ logging library
- pkgver = 9.84
+ pkgver = 9.88
pkgrel = 1
url = https://github.com/easylogging/easyloggingpp
arch = any
license = custom
optdepends = gcc: compiler that supports C++11
- source = https://github.com/easylogging/easyloggingpp/archive/9.84.tar.gz
- sha1sums = df2d504250b5bed5b5c62b7e1d08063979f94e1c
+ source = https://github.com/easylogging/easyloggingpp/releases/download/9.88/easyloggingpp_v9.88.tar.gz
+ sha1sums = 9f465090d725508ef41779ca77c6d92894677caf
pkgname = easyloggingpp
diff --git a/PKGBUILD b/PKGBUILD
index 1d67cde35ff2..b74ee23dd7e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: MadPhysicist <jfoxrabinovitz at gmail dot com>
-pkgname=easyloggingpp
-pkgver=9.84
+_shortname=easylogging
+pkgname=${_shortname}pp
+pkgver=9.88
pkgrel=1
pkgdesc='Robust, thread-safe lightweight single header only C++ logging library'
arch=('any')
-url='https://github.com/easylogging/easyloggingpp'
+url="https://github.com/${_shortname}/${pkgname}"
license=('custom')
groups=()
depends=()
@@ -17,11 +18,12 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/easylogging/easyloggingpp/archive/${pkgver}.tar.gz")
+source=("https://github.com/${_shortname}/${pkgname}/releases/download/${pkgver}/${pkgname}_v${pkgver}.tar.gz")
noextract=()
-sha1sums=('df2d504250b5bed5b5c62b7e1d08063979f94e1c')
+sha1sums=('9f465090d725508ef41779ca77c6d92894677caf')
package() {
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENCE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/src/easylogging++.h" "${pkgdir}/usr/include/easylogging++.h"
+ install -Dm644 "${srcdir}/LICENCE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/easylogging++.h" "${pkgdir}/usr/include/easylogging++.h"
+ install -Dm644 "${srcdir}/RELEASE-NOTES.txt" "${pkgdir}/usr/share/doc/${pkgname}/RELEASE-NOTES"
}