summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Fox-Rabinovitz2015-06-10 17:04:29 -0400
committerJoseph Fox-Rabinovitz2015-06-10 17:04:29 -0400
commit5201c7196df23a1feddbd90d7a08023e59387af6 (patch)
treea55d0f4aa2bf6e81d71a6196ccb171d3c8367124
downloadaur-5201c7196df23a1feddbd90d7a08023e59387af6.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc5234e3a584
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = easyloggingpp
+ pkgdesc = Robust, thread-safe lightweight single header only C++ logging library
+ pkgver = 9.80
+ pkgrel = 1
+ url = https://github.com/easylogging/easyloggingpp
+ arch = any
+ license = custom
+ optdepends = gcc: compiler that supports C++11
+ source = https://raw.githubusercontent.com/easylogging/easyloggingpp/v9.80/src/easylogging++.h
+ source = https://raw.githubusercontent.com/easylogging/easyloggingpp/v9.80/LICENCE
+ sha1sums = 8d9cb14c96f3f12bf5fbfd4e7d7f4b6f8d1e21b3
+ sha1sums = e6539fb007f23ea9dd9582c0780e87ee5aafb28c
+
+pkgname = easyloggingpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cbc37f7fce8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: MadPhysicist <jfoxrabinovitz at gmail dot com>
+pkgname=easyloggingpp
+pkgver=9.80
+pkgrel=1
+pkgdesc='Robust, thread-safe lightweight single header only C++ logging library'
+arch=('any')
+url='https://github.com/easylogging/easyloggingpp'
+license=('custom')
+groups=()
+depends=()
+makedepends=()
+optdepends=('gcc: compiler that supports C++11')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://raw.githubusercontent.com/easylogging/easyloggingpp/v${pkgver}/src/easylogging++.h"
+ "https://raw.githubusercontent.com/easylogging/easyloggingpp/v${pkgver}/LICENCE")
+noextract=()
+sha1sums=('8d9cb14c96f3f12bf5fbfd4e7d7f4b6f8d1e21b3'
+ 'e6539fb007f23ea9dd9582c0780e87ee5aafb28c')
+
+package() {
+ install -Dm644 ${srcdir}/LICENCE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 ${srcdir}/easylogging++.h ${pkgdir}/usr/include/easylogging++.h
+}