summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Finger2023-11-17 16:40:51 +0100
committerEric Finger2023-11-17 16:40:51 +0100
commitd445547044e970f9f829242673ee0818763ba1f9 (patch)
tree1a92aa2f8c0ac004590da0788cdb542372d187fa
downloadaur-d445547044e970f9f829242673ee0818763ba1f9.tar.gz
initial commit - easyroam version 1.3.2
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--.install11
-rw-r--r--PKGBUILD19
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f92df87754f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = easyroam-desktop-bin
+ pkgdesc = Manage and install your easyroam wifi profiles
+ pkgver = 1.3.2
+ pkgrel = 1
+ epoch = 0
+ url = https://www.easyroam.de/
+ install = .install
+ arch = x86_64
+ license = unknown
+ depends = gtk3
+ depends = lz4
+ depends = xz
+ depends = libnm
+ depends = libsecret
+ provides = easyroam-desktop
+ conflicts = easyroam-desktop
+ source = https://www.easyroam.de/debapp/easyroam.deb
+ sha256sums = 5c63d23f8c8f3473be1e3fe69de0c96557206f8f1a39ee53ac8d1ff8c5da73f1
+
+pkgname = easyroam-desktop-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0ae61af6df7d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!.install
+!PKGBUILD
diff --git a/.install b/.install
new file mode 100644
index 000000000000..ad152687e528
--- /dev/null
+++ b/.install
@@ -0,0 +1,11 @@
+post_install() {
+ ln -s /usr/share/easyroam_connect_desktop/easyroam_connect_desktop /usr/bin/easyroam_connect_desktop
+ chmod +x /usr/bin/easyroam_connect_desktop
+ if hash update-desktop-database 2>/dev/null; then
+ update-desktop-database
+ fi
+}
+
+post_remove() {
+ rm /usr/bin/easyroam_connect_desktop
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f0a7cf4ab1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Eric Finger <ericfinger at ericfinger dot com>
+pkgname=easyroam-desktop-bin
+pkgver=1.3.2
+pkgrel=1
+epoch=0
+pkgdesc="Manage and install your easyroam wifi profiles"
+arch=('x86_64')
+url="https://www.easyroam.de/"
+license=('unknown')
+depends=('gtk3' 'lz4' 'xz' 'libnm' 'libsecret')
+provides=('easyroam-desktop')
+conflicts=('easyroam-desktop')
+source=('https://www.easyroam.de/debapp/easyroam.deb')
+sha256sums=('5c63d23f8c8f3473be1e3fe69de0c96557206f8f1a39ee53ac8d1ff8c5da73f1')
+install=".install"
+
+package() {
+ tar -xvf 'data.tar.xz' -C "${pkgdir}"
+}