summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2019-04-07 14:40:14 +0200
committerCarsten Teibes2019-04-07 14:40:14 +0200
commit4c8e6cae3dab25d48f0c7642301cb2fad15472a1 (patch)
treed581900deaf2e6cceaf23968e5d188286ee55c91
parent19e8483bc8965af3da8e5d0e0e747c3547416087 (diff)
downloadaur-4c8e6cae3dab25d48f0c7642301cb2fad15472a1.tar.gz
[upd, fix]
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fc9c9c6eee0..8a8da90f21d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = easyrpg-editor-qt-git
pkgdesc = EasyRPG's Game Editor (QT, development version)
- pkgver = r387.455ec3d
+ pkgver = r442.dd516cd
pkgrel = 1
- url = https://easyrpg.org
+ url = https://easyrpg.org/editor/
install = easyrpg-editor-qt-git.install
arch = i686
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = ninja
depends = liblcf-git
depends = qt5-multimedia
provides = easyrpg-editor-qt
diff --git a/PKGBUILD b/PKGBUILD
index 85f2ace52468..2f8ec321242a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=easyrpg-editor-qt-git
-pkgver=r387.455ec3d
+pkgver=r442.dd516cd
pkgrel=1
pkgdesc="EasyRPG's Game Editor (QT, development version)"
arch=('i686' 'x86_64')
-url="https://easyrpg.org"
+url="https://easyrpg.org/editor/"
license=('GPL3')
conflicts=("${pkgname%-*}")
provides=("${pkgname%-*}")
-makedepends=('git')
depends=('liblcf-git' 'qt5-multimedia')
-install="$pkgname.install"
+makedepends=('git' 'ninja')
+install=$pkgname.install
source=(${pkgname%-*}::"git+https://github.com/EasyRPG/Editor-QT.git")
md5sums=('SKIP')
@@ -20,25 +20,19 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
+build () {
cd ${pkgname%-*}
rm -rf build
- mkdir -p build
-}
-
-build () {
- cd ${pkgname%-*}/build
-
- cmake ../
- make
+ cmake -B build -G Ninja -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package () {
cd ${pkgname%-*}
# binary
- install -Dm755 build/bin/EasyRPG_Editor "$pkgdir"/usr/bin/${pkgname%-*}
+ DESTDIR="$pkgdir" ninja -C build install
# templates
install -d "$pkgdir"/usr/share/${pkgname%-*}/templates
install -m644 bin/templates/* "$pkgdir"/usr/share/${pkgname%-*}/templates