summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-09-01 21:50:04 +0200
committerCarsten Teibes2015-09-01 21:50:04 +0200
commitc1097ac5db2fa4dff7b15f4dbf9f58db9ca0f8e4 (patch)
tree7070f0d7d2bf5ee9a8434c8065fd6ee3f3d87165
parent66d90f22da3b04d4975a9b65660e8ad04120a055 (diff)
downloadaur-c1097ac5db2fa4dff7b15f4dbf9f58db9ca0f8e4.tar.gz
[upd] Add png2xyz tool
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd0d84fa1f42..302fdcdfd8c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = easyrpg-tools-git
pkgdesc = EasyRPG tools to convert RPG Maker 2000/2003 files (development version)
- pkgver = r39.e185825
+ pkgver = r50.aea33a2
pkgrel = 1
url = https://easy-rpg.org/
arch = i686
arch = x86_64
license = MIT
- license = GPL
+ license = GPL3
license = custom
makedepends = git
depends = gcc-libs
depends = liblcf-git
depends = sdl2_image
+ depends = libpng
provides = lcf2xml
provides = lmu2png
+ provides = png2xyz
provides = xyz2png
conflicts = lcf2xml
source = easyrpg-tools-git::git+https://github.com/EasyRPG/tools.git
diff --git a/PKGBUILD b/PKGBUILD
index f53b217948d8..2bf435875a37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=easyrpg-tools-git
-pkgver=r39.e185825
+pkgver=r50.aea33a2
pkgrel=1
pkgdesc="EasyRPG tools to convert RPG Maker 2000/2003 files (development version)"
arch=('i686' 'x86_64')
url="https://easy-rpg.org/"
-license=('MIT' 'GPL' 'custom')
+license=('MIT' 'GPL3' 'custom')
conflicts=('lcf2xml')
-provides=('lcf2xml' 'lmu2png' 'xyz2png')
+provides=('lcf2xml' 'lmu2png' 'png2xyz' 'xyz2png')
makedepends=('git')
-depends=('gcc-libs' 'liblcf-git' 'sdl2_image')
+depends=('gcc-libs' 'liblcf-git' 'sdl2_image' 'libpng')
source=(${pkgname#-*}::"git+https://github.com/EasyRPG/tools.git")
md5sums=('SKIP')
@@ -23,6 +23,7 @@ build () {
cd ${pkgname#-*}
make -C lmu2png
+ make -C png2xyz
make -C xyz2png
# compile with our flags
g++ $CXXFLAGS lcf2xml/src/main.cpp $(pkg-config --cflags --libs liblcf) $LDFLAGS -o lcf2xml/lcf2xml
@@ -33,10 +34,10 @@ package () {
# executables
install -Dm755 lmu2png/lmu2png "$pkgdir"/usr/bin/lmu2png
+ install -Dm755 xyz2png/xyz2png "$pkgdir"/usr/bin/png2xyz
install -Dm755 xyz2png/xyz2png "$pkgdir"/usr/bin/xyz2png
install -Dm755 lcf2xml/lcf2xml "$pkgdir"/usr/bin/lcf2xml
# licenses
install -Dm644 lmu2png/COPYING "$pkgdir"/usr/share/licenses/$pkgname/lmu2png-COPYING
- install -Dm644 xyz2png/COPYING "$pkgdir"/usr/share/licenses/$pkgname/xyz2png-COPYING
install -Dm644 lcf2xml/COPYING "$pkgdir"/usr/share/licenses/$pkgname/lcf2xml-COPYING
}