summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-08-19 19:03:22 +0200
committerFabioLolix2020-08-19 19:03:22 +0200
commit9675ea9b04117303a398e69e2084e407af096720 (patch)
tree55ce9627b0e71ae9dda77d2f17403b843067be1a
parent8035cc6cc5be123de76148deebf7a78d2938cbb9 (diff)
downloadaur-9675ea9b04117303a398e69e2084e407af096720.tar.gz
fix build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c96f4477f3c6..f34e4d66948c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = easyssh-git
pkgdesc = SSH connection manager for Pantheon
- pkgver = 1.6.6.r10.g26d7123a
+ pkgver = 1.7.1.r9.gd43a52d7
pkgrel = 1
url = https://github.com/muriloventuroso/easyssh
arch = x86_64
@@ -15,7 +15,9 @@ pkgbase = easyssh-git
provides = easyssh
conflicts = easyssh
source = git+https://github.com/muriloventuroso/easyssh.git
+ source = https://dev.getsol.us/file/data/j3xcc4frwhf7o7oj5b7q/PHID-FILE-xz47xj55kglr3mr7kyig/files_utf8.patch
sha256sums = SKIP
+ sha256sums = f5b4a7406b61d6f777abdfab6141cbf917ee469c49bac2445bb6d704cb82461f
pkgname = easyssh-git
diff --git a/PKGBUILD b/PKGBUILD
index 11cd7ea02817..0f8d77c02b7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
pkgname=easyssh-git
-pkgver=1.6.6.r10.g26d7123a
+pkgver=1.7.1.r9.gd43a52d7
pkgrel=1
pkgdesc="SSH connection manager for Pantheon"
arch=(x86_64)
@@ -11,21 +11,28 @@ depends=(libgranite.so gtk3 vte3)
makedepends=(vala meson ninja git)
provides=(easyssh)
conflicts=(easyssh)
-source=("git+${url}.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/muriloventuroso/easyssh.git"
+ "https://dev.getsol.us/file/data/j3xcc4frwhf7o7oj5b7q/PHID-FILE-xz47xj55kglr3mr7kyig/files_utf8.patch")
+sha256sums=('SKIP'
+ 'f5b4a7406b61d6f777abdfab6141cbf917ee469c49bac2445bb6d704cb82461f')
+
+prepare() {
+ cd "${srcdir}/${pkgname%-git}"
+ patch -Np1 -i ../files_utf8.patch
+}
pkgver() {
- cd "$srcdir/${pkgname/-git/}"
+ cd "${srcdir}/${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname/-git/}"
+ cd "${srcdir}/${pkgname%-git}"
meson build --prefix=/usr -D libunity=false -D ubuntu-bionic-patched-vte=false
ninja -C build
}
package() {
- cd "$srcdir/${pkgname/-git/}"
+ cd "${srcdir}/${pkgname%-git}"
DESTDIR="${pkgdir}" ninja -C build install
}