summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-07-23 00:37:20 +0200
committerFabioLolix2018-07-23 00:37:20 +0200
commit9762605d3857002d88e6c6a464ddfcbe61f210ad (patch)
treed7a941a04a6e1429c47f3229864be06ec874f9a7
downloadaur-9762605d3857002d88e6c6a464ddfcbe61f210ad.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02fec696851a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = easyssh-git
+ pkgdesc = SSH connection manager for Pantheon
+ pkgver = 1.2.7.r8.g1c2fdeb
+ pkgrel = 1
+ url = https://github.com/muriloventuroso/easyssh
+ arch = x86_64
+ license = GPL3
+ makedepends = vala
+ makedepends = meson
+ makedepends = ninja
+ makedepends = git
+ depends = libgranite.so
+ depends = gtk3
+ provides = easyssh
+ conflicts = easyssh
+ source = easyssh-git::git+https://github.com/muriloventuroso/easyssh.git
+ sha256sums = SKIP
+
+pkgname = easyssh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bedf6b75c0b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+
+pkgname=easyssh-git
+pkgver=1.2.7.r8.g1c2fdeb
+pkgrel=1
+pkgdesc="SSH connection manager for Pantheon"
+arch=('x86_64')
+url='https://github.com/muriloventuroso/easyssh'
+license=('GPL3')
+depends=('libgranite.so' 'gtk3')
+makedepends=('vala' 'meson' 'ninja' 'git')
+provides=(easyssh)
+conflicts=(easyssh)
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ meson build --prefix=/usr
+ ninja -C build
+}
+
+package() {
+ cd "${pkgname}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}