summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Finkel2022-06-23 18:40:31 -0400
committerSteve Finkel2022-06-23 18:40:31 -0400
commit2f0ab128466bf1da496e0f17bf2386379d07c0f7 (patch)
treebdfa98c7bab36d75f80ce16a9d21e367f927cb5f
parentadcbad83cbb06591b8ec2d8e4ac0a5b976744d89 (diff)
downloadaur-2f0ab128466bf1da496e0f17bf2386379d07c0f7.tar.gz
recompiled for newer boost-libs
-rw-r--r--.SRCINFO15
-rwxr-xr-x[-rw-r--r--]PKGBUILD26
2 files changed, 15 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9bbc8b91eed..7a6bb7634210 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = easystroke
- pkgdesc = Use mouse gestures to initiate commands and hotkeys.
+ pkgdesc = Use mouse gestures to initiate commands and hotkeys
pkgver = 0.6.0
- pkgrel = 22
- url = http://easystroke.sourceforge.net/
+ pkgrel = 23
+ url = https://github.com/mrsteve0924/easystroke
arch = x86_64
license = custom:ISC
makedepends = boost
@@ -16,12 +16,7 @@ pkgbase = easystroke
depends = libxtst
depends = dbus-glib
depends = xorg-server
- source = https://downloads.sourceforge.net/easystroke/easystroke-0.6.0.tar.gz
- source = easystroke-0.6.0-gcc7-build-fix.patch
- source = replace-sigc-group-with-lambda.patch
- sha512sums = a74cbdfd2b56e6b20d895297e80fb63f3d8ac938235ecf7067f984d087004af22a5ea0116ae20b948e238b02a06b14044a7025d65840f0c8d00542332387c921
- sha512sums = ab243cd570a4878767bfc64f39dbf6cc938bf050b50e4ac3bfe5036f5fbdd21eeeedc5cf89784a4f73f78233132b981d00087482835430d240f0b55e16d1acb4
- sha512sums = 30b3a50b3434b22d3aed75f8c023eafb78f6980a23c506e9ed70e8787fd2786a1a882468b5c8334e3161c241c1878f8b4f9ba0178e07aad0388d44522e70c245
+ source = easystroke-0.6.0.tar.gz::https://github.com/mrsteve0924/easystroke/archive/v0.6.0.tar.gz
+ sha256sums = c5851abd8b1b77d494eff108b2c0e2cc8cf689800bcfb2eead9f5e68274b37f9
pkgname = easystroke
-
diff --git a/PKGBUILD b/PKGBUILD
index ce83ac719bb2..9ecd9bddce32 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,25 @@
-# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Maintainer: Raymond Li <aur@raymond.li>
+# Co-maintainer: Steve Finkel <mrsteve0924@verizon.net>
+# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Kevin Sullivan <ksullivan@archlinux.us>
pkgname=easystroke
pkgver=0.6.0
-pkgrel=22
-pkgdesc='Use mouse gestures to initiate commands and hotkeys.'
+pkgrel=23
+pkgdesc='Use mouse gestures to initiate commands and hotkeys'
arch=('x86_64')
-url='http://easystroke.sourceforge.net/'
+url='https://github.com/mrsteve0924/easystroke'
license=('custom:ISC')
depends=('gtkmm3' 'boost-libs' 'libxtst' 'dbus-glib' 'xorg-server')
makedepends=('boost' 'xorgproto' 'intltool' 'gettext' 'xorg-server-devel' 'help2man')
-source=("https://downloads.sourceforge.net/easystroke/${pkgname}-${pkgver}.tar.gz"
- 'easystroke-0.6.0-gcc7-build-fix.patch'
- 'replace-sigc-group-with-lambda.patch')
-sha512sums=('a74cbdfd2b56e6b20d895297e80fb63f3d8ac938235ecf7067f984d087004af22a5ea0116ae20b948e238b02a06b14044a7025d65840f0c8d00542332387c921'
- 'ab243cd570a4878767bfc64f39dbf6cc938bf050b50e4ac3bfe5036f5fbdd21eeeedc5cf89784a4f73f78233132b981d00087482835430d240f0b55e16d1acb4'
- '30b3a50b3434b22d3aed75f8c023eafb78f6980a23c506e9ed70e8787fd2786a1a882468b5c8334e3161c241c1878f8b4f9ba0178e07aad0388d44522e70c245')
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mrsteve0924/${pkgname}/archive/v${pkgver}.tar.gz")
+
+sha256sums=('c5851abd8b1b77d494eff108b2c0e2cc8cf689800bcfb2eead9f5e68274b37f9')
prepare() {
cd "${pkgname}-${pkgver}"
- # Fix compilation with GCC 7.
- patch -Np1 -i ../easystroke-0.6.0-gcc7-build-fix.patch
-
- # fix build with libsigc++ 2.6; also build in C++11 mode
- # (not sure if the lambda is correct, but seems to work)
- patch -Np1 -i ../replace-sigc-group-with-lambda.patch
}
build() {