summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2023-02-11 19:39:13 +0100
committersoloturn2023-02-11 19:39:13 +0100
commit1fb0d7eeca6fe8d981df9f082d9096b449e5c45e (patch)
tree51740ce36c748a3314a7c07f2b92f6d6edfa992f
parentce8a7b66ff5a1c7bf2f13f203138ae3e760aa60d (diff)
downloadaur-1fb0d7eeca6fe8d981df9f082d9096b449e5c45e.tar.gz
correct java-8 via icon start and patch, tx dani wilhelm
-rw-r--r--PKGBUILD24
-rw-r--r--Wappen_Aargau.svg130
-rw-r--r--easytax-ag-2021.desktop8
-rw-r--r--easytax-ag.patch11
4 files changed, 162 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0f43b80048b..cef1a64e4292 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,43 @@
# Maintainer: Daniel Wilhelm <concat(shield, wed) @ outlook.com>
# Maintainer: soloturn@gmail.com
-yyyy=2021
-pkgname=easytax-ag-${yyyy}
+_yyyy=2021
+pkgname=easytax-ag-${_yyyy}
pkgver=1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Aargau tax declaration software."
arch=(any)
url="https://www.ag.ch/de/dfr/steuern/natuerliche_personen/steuererklaerung__easytax/steuererklaerung_easytax1.jsp"
license=('custom')
-depends=("java-environment" "bash")
+depends=("jre8-openjdk")
source=(
- "https://msg-easytax.ch/ag/${yyyy}/EasyTax${yyyy}AG_unix_$(echo ${pkgver} | sed 's/\./_/').tar.gz"
+ "https://msg-easytax.ch/ag/${_yyyy}/EasyTax${_yyyy}AG_unix_$(echo ${pkgver} | sed 's/\./_/').tar.gz"
+ "https://upload.wikimedia.org/wikipedia/commons/d/d9/Wappen_Aargau.svg"
"$pkgname.desktop"
+ "easytax-ag.patch"
)
sha256sums=(
'1dce65837fe258fda921035f11e724d6d19680c6ca6cab94e0551a8dd406be18'
- '1e2cb8dcefd5c891339d064997d2ffd4370bee8def3dee37b962e8e6b487f342'
+ '253d315b20371cd9add777dc990f96545c60d5d07a3f34cd33720d5148e82486'
+ '3a92fb4332f4e731ecb8f5394d0cc923b7edd761c25f32795517f2099c029d1b'
+ '4341d0b441118509ec21539aed95e2a1ac33c88deba0a341af075db114cca8bd'
)
package() {
+ # only necessary to set openjdk as its default
+ patch "$srcdir"/EasyTax*AG/EasyTax*_AG <"$srcdir"/easytax-ag.patch
+
# package the software, the xdg desktop file so GUI finds it
# and the link in bin so commandline finds it.
mkdir -p "$pkgdir"/usr/lib
- mv "$srcdir"/EasyTax${yyyy}AG/ "$pkgdir"/usr/lib/$pkgname/
+ mv "$srcdir"/EasyTax${_yyyy}AG/ "$pkgdir"/usr/lib/$pkgname/
mkdir -p "$pkgdir"/usr/share/applications
cp *.desktop "$pkgdir"/usr/share/applications/
+ mkdir -p "$pkgdir"/usr/share/icons/hicolor/scalable/apps/
+ cp Wappen_Aargau.svg "$pkgdir"/usr/share/icons/hicolor/scalable/apps/wappen-aargau-${_yyyy}.svg
+
mkdir -p "$pkgdir"/usr/bin
binname=$(basename "$pkgdir"/usr/lib/$pkgname/EasyTax*)
ln -sf /usr/lib/${pkgname}/$binname "$pkgdir"/usr/bin/$pkgname
diff --git a/Wappen_Aargau.svg b/Wappen_Aargau.svg
new file mode 100644
index 000000000000..2987b49b7a74
--- /dev/null
+++ b/Wappen_Aargau.svg
@@ -0,0 +1,130 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://web.resource.org/cc/"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="219"
+ height="266"
+ id="svg2"
+ sodipodi:version="0.32"
+ inkscape:version="0.44"
+ version="1.0"
+ sodipodi:docbase="C:\Dokumente und Einstellungen\Christian\Eigene Dateien\Wikipedia\ToSVG"
+ sodipodi:docname="Aargau.svg">
+ <defs
+ id="defs4" />
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="4"
+ inkscape:cx="64.59536"
+ inkscape:cy="161.2241"
+ inkscape:document-units="mm"
+ inkscape:current-layer="layer1"
+ showgrid="true"
+ width="219px"
+ height="266px"
+ units="mm"
+ showborder="false"
+ inkscape:showpageshadow="false"
+ inkscape:window-width="931"
+ inkscape:window-height="940"
+ inkscape:window-x="-4"
+ inkscape:window-y="-4" />
+ <metadata
+ id="metadata7">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:label="Ebene 1"
+ inkscape:groupmode="layer"
+ id="layer1"
+ transform="translate(-287.2817,864.3134)">
+ <rect
+ style="opacity:1;fill:white;fill-opacity:1;fill-rule:nonzero;stroke:none;stroke-width:2.41653538;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+ id="rect2884"
+ width="106"
+ height="62"
+ x="290.28171"
+ y="-773.06342" />
+ <path
+ style="opacity:1;fill:black;fill-opacity:1;fill-rule:nonzero;stroke:none;stroke-opacity:1"
+ d="M 289.55335,-864.74135 L 289.05335,-700.08505 C 289.05336,-644.88223 337.70463,-600.08504 397.6471,-600.08505 C 457.58957,-600.08507 506.74085,-644.88221 506.74085,-700.08505 L 506.49085,-864.74135 L 289.55335,-864.74135 z M 452.24085,-862.36635 C 470.38167,-862.34665 488.0941,-862.30375 503.5846,-862.30385 L 503.7721,-704.2413 C 505.77211,-644.27934 455.92159,-602.36628 397.9596,-602.3663 L 398.3971,-862.33505 C 415.55573,-862.36865 434.10003,-862.38555 452.24085,-862.36635 z M 347.30335,-773.21005 C 353.23532,-772.88981 362.481,-766.74363 365.74085,-766.9913 C 373.81411,-767.60464 376.7009,-773.01176 384.5846,-773.02255 C 392.59237,-773.03352 395.92204,-768.39618 396.7721,-768.08505 C 396.7721,-749.4817 396.74822,-731.90825 396.67835,-713.2413 C 396.16878,-713.67828 393.12362,-716.75226 385.11585,-716.7413 C 377.23215,-716.7305 373.80391,-711.66415 365.74085,-710.9288 C 361.77703,-710.5673 353.10537,-716.68252 345.0221,-716.2413 C 337.06509,-715.80009 330.78697,-710.88951 325.7096,-710.6788 C 322.2069,-710.53345 311.42901,-715.92032 305.30335,-715.9913 C 297.98918,-716.07608 291.93262,-711.40398 290.55335,-710.9913 C 290.57949,-717.20624 290.5731,-723.52995 290.5846,-729.83505 L 290.4596,-729.83505 C 290.49507,-729.83874 290.54644,-729.8597 290.5846,-729.8663 C 290.59619,-736.22992 290.61309,-742.55134 290.61585,-748.9288 C 290.61848,-755.00054 290.61585,-761.10122 290.61585,-767.1163 C 294.222,-767.15818 297.1375,-771.94044 304.24085,-772.1163 C 311.40735,-772.29215 319.70296,-766.65715 324.61585,-766.8038 C 330.49116,-766.97921 340.39683,-772.6419 346.1471,-773.1788 C 346.5104,-773.21272 346.90789,-773.2314 347.30335,-773.21005 z "
+ id="path1905"
+ sodipodi:nodetypes="ccsccccccccccssccsscssccccsccssc" />
+ <path
+ style="opacity:1;fill:blue;fill-opacity:1;fill-rule:nonzero;stroke:none;stroke-opacity:1"
+ d="M 397.85675,-862.49605 L 397.94514,-602.12903 C 454.73123,-602.23259 506.12408,-643.82901 504.11733,-703.992 L 504.11733,-862.58444 C 468.87388,-862.63316 433.10021,-862.55682 397.85675,-862.49605 z M 425.50946,-787.11348 L 431.68647,-771.02848 L 448.49293,-770.05649 L 435.1042,-759.20774 L 439.36853,-742.90326 L 424.91371,-752.30969 L 410.74109,-743.21681 L 415.19355,-759.86619 L 402.18108,-770.52681 L 419.39517,-771.4361 L 425.50946,-787.11348 z M 477.37122,-786.2669 L 483.61093,-770.21326 L 500.44876,-769.33533 L 487.09138,-758.42387 L 491.44977,-742.15075 L 476.9636,-751.46311 L 462.82233,-742.30752 L 467.21208,-758.98826 L 454.1369,-769.58617 L 471.31963,-770.55816 L 477.37122,-786.2669 z M 451.31492,-741.99398 L 457.89954,-726.06576 L 474.73737,-725.56408 L 461.66218,-714.37043 L 466.36549,-698.19137 L 451.65983,-707.19019 L 437.73805,-697.72105 L 441.75153,-714.46449 L 428.42551,-724.78021 L 445.60824,-726.12847 L 451.31492,-741.99398 z "
+ id="path1890"
+ sodipodi:nodetypes="cccccccccccccccccccccccccccccccccccccc" />
+ <path
+ sodipodi:type="star"
+ style="opacity:1;fill:white;fill-opacity:1;fill-rule:nonzero;stroke:black;stroke-width:0.99664938;stroke-opacity:1"
+ id="path2819"
+ sodipodi:sides="5"
+ sodipodi:cx="-137.38075"
+ sodipodi:cy="-938.08154"
+ sodipodi:r1="24.266741"
+ sodipodi:r2="10.427473"
+ sodipodi:arg1="-1.5470884"
+ sodipodi:arg2="-0.89679994"
+ inkscape:flatsided="false"
+ inkscape:rounded="0"
+ inkscape:randomized="0"
+ d="M -136.80549,-962.34146 L -130.87283,-946.22888 L -114.13043,-945.03117 L -127.62112,-934.4098 L -123.58652,-918.11672 L -137.85689,-927.66495 L -152.10577,-918.79298 L -147.43466,-935.31547 L -160.27554,-946.12538 L -143.11827,-946.78861 L -136.80549,-962.34146 z "
+ transform="matrix(1.003288,-1.29927e-2,1.299295e-2,1.003269,575.1855,176.6254)" />
+ <path
+ sodipodi:type="star"
+ style="opacity:1;fill:white;fill-opacity:1;fill-rule:nonzero;stroke:black;stroke-width:0.99664938;stroke-opacity:1"
+ id="path2821"
+ sodipodi:sides="5"
+ sodipodi:cx="-137.38075"
+ sodipodi:cy="-938.08154"
+ sodipodi:r1="24.266741"
+ sodipodi:r2="10.427473"
+ sodipodi:arg1="-1.5470884"
+ sodipodi:arg2="-0.89679994"
+ inkscape:flatsided="false"
+ inkscape:rounded="0"
+ inkscape:randomized="0"
+ d="M -136.80549,-962.34146 L -130.87283,-946.22888 L -114.13043,-945.03117 L -127.62112,-934.4098 L -123.58652,-918.11672 L -137.85689,-927.66495 L -152.10577,-918.79298 L -147.43466,-935.31547 L -160.27554,-946.12538 L -143.11827,-946.78861 L -136.80549,-962.34146 z "
+ transform="matrix(1.003211,-1.799397e-2,1.799431e-2,1.003192,631.9164,176.6208)" />
+ <path
+ sodipodi:type="star"
+ style="opacity:1;fill:white;fill-opacity:1;fill-rule:nonzero;stroke:black;stroke-width:0.99664938;stroke-opacity:1"
+ id="path2823"
+ sodipodi:sides="5"
+ sodipodi:cx="-137.38075"
+ sodipodi:cy="-938.08154"
+ sodipodi:r1="24.266741"
+ sodipodi:r2="10.427473"
+ sodipodi:arg1="-1.5470884"
+ sodipodi:arg2="-0.89679994"
+ inkscape:flatsided="false"
+ inkscape:rounded="0"
+ inkscape:randomized="0"
+ d="M -136.80549,-962.34146 L -130.87283,-946.22888 L -114.13043,-945.03117 L -127.62112,-934.4098 L -123.58652,-918.11672 L -137.85689,-927.66495 L -152.10577,-918.79298 L -147.43466,-935.31547 L -160.27554,-946.12538 L -143.11827,-946.78861 L -136.80549,-962.34146 z "
+ transform="matrix(1.002552,-4.055163e-2,4.05524e-2,1.002533,627.5247,216.9188)" />
+ <path
+ id="path2855"
+ style="fill:none;fill-opacity:1;fill-rule:evenodd;stroke:black;stroke-width:2.41653538;stroke-linecap:butt;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+ d="M 305.61444,-715.3749 C 311.74009,-715.30389 322.5042,-709.94053 326.00691,-710.08588 C 331.08427,-710.29658 337.36907,-715.18624 345.32607,-715.62745 C 353.40933,-716.06866 362.07037,-709.96265 366.03419,-710.32415 C 374.09724,-711.0595 377.53224,-716.11388 385.41595,-716.12468 C 393.42372,-716.13565 396.46728,-713.08178 396.97685,-712.6448 C 397.04847,-730.92778 397.07266,-749.21089 397.07555,-767.49399 C 396.22548,-767.80515 392.88708,-772.4201 384.8793,-772.40913 C 376.9956,-772.39833 374.10744,-767.00096 366.03419,-766.38762 C 362.55702,-766.12345 352.27535,-773.11751 346.46249,-772.5748 C 340.71222,-772.03793 330.80892,-766.38789 324.93362,-766.21248 C 320.02071,-766.06581 311.70765,-771.67735 304.54117,-771.5015 C 297.43779,-771.32566 294.538,-766.54896 290.93185,-766.50708 C 290.93185,-757.2054 290.89301,-719.63315 290.85417,-710.39834 M 290.85417,-710.39834 C 292.23343,-710.81099 298.30027,-715.45968 305.61444,-715.3749 M 290.91045,-748.34012 C 293.38209,-748.79553 299.2771,-753.50035 306.28408,-753.45945 C 312.41005,-753.4237 319.85192,-748.2317 326.36045,-748.34541 C 333.03192,-748.45888 336.024,-752.47673 345.65436,-753.3819 C 351.68997,-753.9492 356.66248,-747.55148 364.29167,-748.0786 C 372.36894,-748.63668 375.41426,-754.38646 383.29462,-754.15693 C 390.8432,-753.94221 395.09989,-749.79205 396.84384,-749.3918 M 290.77784,-729.23926 C 292.74948,-729.44467 298.9105,-734.22989 305.9175,-734.18899 C 312.04347,-734.15324 322.80725,-728.75462 326.30997,-728.89997 C 331.38733,-729.11067 340.20715,-733.90467 345.95742,-734.44154 C 351.77028,-734.98425 357.10221,-728.6973 364.822,-729.13824 C 372.90535,-729.59996 375.39344,-734.72488 382.97723,-734.77553 C 390.53059,-734.82596 396.38914,-730.61818 396.89614,-730.27466"
+ sodipodi:nodetypes="cscssccsssszcccscsssssccsssssc" />
+ </g>
+</svg>
diff --git a/easytax-ag-2021.desktop b/easytax-ag-2021.desktop
index 9265f3e0371b..5b2f1cf36a66 100644
--- a/easytax-ag-2021.desktop
+++ b/easytax-ag-2021.desktop
@@ -1,7 +1,7 @@
#!/usr/bin/env xdg-open
[Desktop Entry]
-Type=Application
-Name=EasyTax 2021 AG
-Exec=INSTALL4J_JAVA_HOME=/usr/lib/jvm/java-8-openjdk/jre /bin/sh -c /usr/bin/easytax-ag-2021
Categories=Office;
-
+Exec=/usr/bin/easytax-ag-2021
+Icon=wappen-aargau-2021
+Name=EasyTax 2021 AG
+Type=Application
diff --git a/easytax-ag.patch b/easytax-ag.patch
new file mode 100644
index 000000000000..300db7623a9c
--- /dev/null
+++ b/easytax-ag.patch
@@ -0,0 +1,11 @@
+--- EasyTax2022_AG.orig 2022-03-26 12:21:02.000000000 +0100
++++ EasyTax2022_AG 2022-03-26 12:55:34.600379348 +0100
+@@ -1,7 +1,7 @@
+ #!/bin/sh
+
+ # Uncomment the following line to override the JVM search sequence
+-# INSTALL4J_JAVA_HOME_OVERRIDE=
++INSTALL4J_JAVA_HOME_OVERRIDE=/usr/lib/jvm/java-8-openjdk/jre
+ # Uncomment the following line to add additional VM parameters
+ # INSTALL4J_ADD_VM_PARAMS=
+