summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2015-10-21 17:37:39 -0400
committerYour Name2015-10-21 17:37:39 -0400
commit726e883b0464c77dfaa1e09fc79c18db7c55e371 (patch)
treed815a92ddca481e112ab3b85406c07bfe397d779
downloadaur-726e883b0464c77dfaa1e09fc79c18db7c55e371.tar.gz
First commit of pkgbuild and srcinfo files
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD46
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9a0d5dee9e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = easyterm
+ pkgdesc = Serial Port Terminal Emulator
+ pkgver = 0.9
+ pkgrel = 6
+ url = http://sourceforge.net/projects/easyterm/
+ arch = x86_64
+ arch = i686
+ license = GPLv3
+ makedepends = git
+
+pkgname = easyterm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a6d60f1f920
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Christopher Hamilton <marker5a@gmail.com>
+
+pkgname=easyterm
+pkgver=0.9
+pkgrel=6
+pkgdesc='Serial Port Terminal Emulator'
+arch=('x86_64' 'i686')
+url='http://sourceforge.net/projects/easyterm/'
+
+license=('GPLv3')
+depends=('qt5')
+depends=()
+makedepends=('git')
+optdepends=()
+provides=()
+conflicts=()
+source=()
+md5sums=()
+_gitroot="http://git.code.sf.net/p/easyterm/code easyterm"
+_gitname="easyterm"
+
+build() {
+ cd ${srcdir}/
+
+ msg "Connecting to the GIT server...."
+ if [[ -d ${srcdir}/${_gitname} ]] ; then
+ cd ${_gitname}
+ git pull origin
+ msg "The local files are updated..."
+ else
+ git clone ${_gitroot}
+ fi
+
+ cd ${_gitname}
+
+
+ qmake .
+ make
+}
+
+package() {
+ cd "easyterm-code"
+
+}
+
+# vim:set ts=2 sw=2 et: