summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPouar2015-06-08 15:52:43 -0500
committerPouar2015-06-08 15:52:43 -0500
commit897ccfeccb9b0c345fe38d2a1725586242ae493c (patch)
treebfa37918d50323d82a59e38e652ac57bfc3ac58b
downloadaur-897ccfeccb9b0c345fe38d2a1725586242ae493c.tar.gz
port from aur3
-rw-r--r--.SRCINFO20
-rw-r--r--CHANGELOG12
-rw-r--r--PKGBUILD37
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5b20f9650c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 4.2.1
+# Thu May 14 21:13:46 UTC 2015
+pkgbase = easytether-bin
+ pkgdesc = Internet access via smartphone
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = http://www.mobile-stream.com/easytether/drivers.html
+ changelog = CHANGELOG
+ arch = i686
+ arch = x86_64
+ license = unknown:freeware
+ depends = glibc
+ depends = libusb
+ depends = udev
+ conflicts = easytether-rpm
+ source = http://www.mobile-stream.com/beta/ubuntu/12.04/easytether_0.8.4-1_amd64.deb
+ md5sums = 5651c1ef7aa83735f435f0e5081f9b23
+
+pkgname = easytether-bin
+
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..88ae6f638e67
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,12 @@
+0.7.2-1
+PKGBUILD is now more optimized
+0.7.2-2
+added md5sums despite them being binaries and including both architectures
+0.7.2-3
+accedently got the changelogs mixed up with easytether-rpm, fixed it
+0.7.3-1
+update to 0.7.3
+0.7.3-2
+moved /lib to /usr/lib for new glib package
+0.7.3-3
+forgot to include changelog
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56306619a226
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Pouar <thepouar@gmail.com>
+
+pkgname=easytether-bin
+pkgver=0.8.4
+pkgrel=1
+_debrel=1
+pkgdesc="Internet access via smartphone"
+arch=(i686 x86_64)
+url=http://www.mobile-stream.com/easytether/drivers.html
+license=(unknown:freeware)
+depends=(glibc libusb udev)
+conflicts=('easytether-rpm')
+_filearch=i386
+[ "${CARCH}" == "x86_64" ] && _filearch=amd64
+_file=easytether_${pkgver}-${_debrel}_${_filearch}.deb
+source=("http://www.mobile-stream.com/beta/ubuntu/12.04/${_file}")
+_extglob="!(*.deb)" # for some reason makepkg doesnt parse extglob correctly, this is a workaround
+changelog=CHANGELOG
+[ $CARCH == i686 ] && md5sums=('5b1bbf7d7effc6d345a0c730a494a18d')
+[ $CARCH == x86_64 ] && md5sums=('5651c1ef7aa83735f435f0e5081f9b23')
+
+build()
+{
+ cd ${srcdir}
+ bsdtar -xf "${_file}" data.tar.gz
+ bsdtar -xf data.tar.gz
+ rm data.tar.gz control.tar.gz debian-binary
+}
+
+package()
+{
+ cd ${srcdir}
+ install -Dm755 ./usr/bin/easytether-usb ${pkgdir}/usr/bin/easytether-usb
+ install -Ddm755 ${pkgdir}/var/lib/easytether/empty
+}
+
+