summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens John2015-06-08 20:35:26 +0200
committerJens John2015-06-08 20:35:26 +0200
commit11b246062d53a09d6da93bc877c8ef42884d0e0a (patch)
tree592d8cb32638d87ab02465f50b5d483342ccd673
downloadaur-11b246062d53a09d6da93bc877c8ef42884d0e0a.tar.gz
Import package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e6027f80982
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = eb-library
+ pkgdesc = EB library for several dictionary formats, including EPWING
+ pkgver = 4.4.3
+ pkgrel = 1
+ url = http://www.sra.co.jp/people/m-kasahr/eb/
+ arch = any
+ license = BSD
+ depends = perl
+ options = !libtool
+ source = ftp://ftp.sra.co.jp/pub/misc/eb/eb-4.4.3.tar.bz2
+ md5sums = 17dd1fade7ba0b82ce6e60f19fcbc823
+
+pkgname = eb-library
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1b66ff0899d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: 2ion <dev@2ion.de>
+# Former maintainer: TDY <tdy@archlinux.info>
+# Contributor: muflax <muflax@gmail.com>
+pkgname=eb-library
+pkgver=4.4.3
+pkgrel=1
+pkgdesc="EB library for several dictionary formats, including EPWING"
+arch=('any')
+url="http://www.sra.co.jp/people/m-kasahr/eb/"
+license=('BSD')
+depends=('perl')
+options=('!libtool')
+source=(ftp://ftp.sra.co.jp/pub/misc/eb/eb-$pkgver.tar.bz2)
+md5sums=('17dd1fade7ba0b82ce6e60f19fcbc823')
+
+build() {
+ cd "$srcdir/eb-$pkgver"
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$srcdir/eb-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: