summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Sim2020-01-18 21:15:27 +0100
committerSam Sim2020-01-18 21:15:27 +0100
commitec3013d30fd49d677772d4343edd77039162a905 (patch)
tree2e0d3678bdadfee7bd24dccdc114965c38d18fd6
downloadaur-ec3013d30fd49d677772d4343edd77039162a905.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..678b2e758b6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ebgaramond-otf
+ pkgdesc = EB Garamond (OTF version) by Octavio Pardo & Georg Duffner
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/octaviopardo/EBGaramond12
+ arch = any
+ license = OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/octaviopardo/EBGaramond12/archive/master.zip
+ sha256sums = a08f5d1e0ad1976330e1c5e57faf384a27628323eaacf797644a3c42bcabac73
+
+pkgname = ebgaramond-otf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b262a66f52a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Sam Simons <contact at sam-simons dot nl>
+# (Loosely) based on otf-inter by Ward Segers & otf-eb-garamond by OmeGa
+pkgname=ebgaramond-otf
+_pkgname=EBGaramond12
+pkgver=1.0
+pkgrel=1
+pkgdesc='EB Garamond (OTF version) by Octavio Pardo & Georg Duffner'
+arch=('any')
+url='https://github.com/octaviopardo/EBGaramond12'
+license=('OFL')
+depends=('fontconfig' 'xorg-font-utils')
+source=("https://github.com/octaviopardo/$_pkgname/archive/master.zip")
+sha256sums=('a08f5d1e0ad1976330e1c5e57faf384a27628323eaacf797644a3c42bcabac73')
+
+package() {
+ install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/OFL.TXT"
+
+ cd "$srcdir/$_pkgname-master/fonts/otf"
+ install -d "$pkgdir/usr/share/fonts/$_pkgname-otf"
+ install -m644 otf/*.otf "$pkgdir/usr/share/fonts/$_pkgname-otf/"
+}
+
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s
+ mkfontscale /usr/share/fonts/$_pkgname-otf
+ mkfontdir /usr/share/fonts/$_pkgname-otf
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}