summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 18:04:55 -0600
committernot_anonymous2015-07-05 18:04:55 -0600
commit0ff499522a710da447f2f61ef6deffa1ae71b06d (patch)
tree1c98f97bf01f5795b22d0ddb1642de9e8141466c
downloadaur-0ff499522a710da447f2f61ef6deffa1ae71b06d.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
-rw-r--r--diff.Makefile5
-rw-r--r--ebook2cwgui.desktop15
-rw-r--r--ebook2cwgui.install11
-rw-r--r--ebook2cwgui.pngbin0 -> 1099 bytes
6 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2c864fc41d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ebook2cwgui
+ pkgdesc = Converts plain text files to Morse Code formatted as MP3 or OGG - GUI
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = http://fkurz.net/ham/ebook2cw.html
+ install = ebook2cwgui.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ebook2cw
+ depends = wxgtk2.8
+ depends = desktop-file-utils
+ source = http://fkurz.net/ham/ebook2cw/ebook2cwgui-0.1.2.tar.gz
+ source = diff.Makefile
+ source = ebook2cwgui.png
+ source = ebook2cwgui.desktop
+ md5sums = 89632a392956a9f3fc66461dfa4e08c6
+ md5sums = dee85b87632c1cbf636f2b3b85d2fd0f
+ md5sums = b23814eeb1e021202b0cf5a5eed15102
+ md5sums = 948dbd30b84fcc7222e723a6ec05f7d6
+ sha256sums = 211c5593f65743d33c5fb3ce98b118592a7b15c8b807fde34a10660d6ff0812c
+ sha256sums = 8eaa197a372addf48a8327b0d05658480696483d796ea8967f9cb17af8b97b3d
+ sha256sums = d8990f54e315d9bdba11f4424734b668460f20f20d23f3539b34d5b6d8170125
+ sha256sums = d10ad0311df45cce7696025ac8bf91648f1090caf353707d01f39784ad03e240
+
+pkgname = ebook2cwgui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6b5e50d4f88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=ebook2cwgui
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Converts plain text files to Morse Code formatted as MP3 or OGG - GUI"
+arch=('i686' 'x86_64')
+url="http://fkurz.net/ham/ebook2cw.html"
+license=('GPL')
+depends=('ebook2cw' 'wxgtk2.8' 'desktop-file-utils')
+install=$pkgname.install
+source=(http://fkurz.net/ham/ebook2cw/${pkgname}-${pkgver}.tar.gz
+ diff.Makefile
+ $pkgname.png
+ $pkgname.desktop)
+
+prepare() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ patch -p0 < ../diff.Makefile
+}
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make all
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}/usr" install
+
+ mkdir -p $pkgdir/usr/share/{applications,pixmaps}
+ install -D -m 644 ../$pkgname.png $pkgdir/usr/share/pixmaps
+ install -D -m 644 ../$pkgname.desktop $pkgdir/usr/share/applications
+
+}
+md5sums=('89632a392956a9f3fc66461dfa4e08c6'
+ 'dee85b87632c1cbf636f2b3b85d2fd0f'
+ 'b23814eeb1e021202b0cf5a5eed15102'
+ '948dbd30b84fcc7222e723a6ec05f7d6')
+sha256sums=('211c5593f65743d33c5fb3ce98b118592a7b15c8b807fde34a10660d6ff0812c'
+ '8eaa197a372addf48a8327b0d05658480696483d796ea8967f9cb17af8b97b3d'
+ 'd8990f54e315d9bdba11f4424734b668460f20f20d23f3539b34d5b6d8170125'
+ 'd10ad0311df45cce7696025ac8bf91648f1090caf353707d01f39784ad03e240')
diff --git a/diff.Makefile b/diff.Makefile
new file mode 100644
index 000000000000..df092a6ea8a7
--- /dev/null
+++ b/diff.Makefile
@@ -0,0 +1,5 @@
+--- Makefile 2013-01-23 10:44:04.000000000 -0700
++++ Makefile 2015-01-27 15:39:17.212190481 -0700
+@@ -12 +12 @@
+- -Wall `wx-config --libs --cxxflags` -o ebook2cwgui
++ -Wall `wx-config-2.8 --libs --cxxflags` -o ebook2cwgui
diff --git a/ebook2cwgui.desktop b/ebook2cwgui.desktop
new file mode 100644
index 000000000000..d25a14944334
--- /dev/null
+++ b/ebook2cwgui.desktop
@@ -0,0 +1,15 @@
+[Desktop Entry]
+Name=Ebook2CW
+Name[en_US]=Ebook2CW
+Comment=Text to Morse Code Converter
+Comment[en_US]=Text to Morse Code Converter
+Encoding=UTF-8
+Exec=ebook2cwgui
+Icon=eboo2cwgui.png
+MimeType=text/plain
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;HamRadio;
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/ebook2cwgui.install b/ebook2cwgui.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/ebook2cwgui.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/ebook2cwgui.png b/ebook2cwgui.png
new file mode 100644
index 000000000000..76ee4b2d098b
--- /dev/null
+++ b/ebook2cwgui.png
Binary files differ