summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbar0metr2018-08-01 20:22:13 +0500
committerbar0metr2018-08-01 20:22:13 +0500
commitb51b5fd10884cfc7c90aaae66128c43cd9a10f56 (patch)
tree68d9de2c21523256b2075f89054f4d364ade54f1
parent30053543656ecf7455ffe9ed7d71f825b54483fd (diff)
downloadaur-b51b5fd10884cfc7c90aaae66128c43cd9a10f56.tar.gz
Replace PKGBUILD (add patches)
-rw-r--r--PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06293d15bd69..2ddd24630059 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,6 +14,20 @@ license=('GPL')
sha256sums=('SKIP')
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ msg "Preparing eCAP adapters src..."
+ msg2 "Getting the replacement patch..."
+ wget https://raw.githubusercontent.com/bar0metr/ecap_adapter_sample/master/replacement.patch
+ msg2 "Patching..."
+ patch -p0 -i replacement.patch
+ msg2 "Getting the adapter_async patch..."
+ wget https://raw.githubusercontent.com/bar0metr/ecap_adapter_sample/master/adapter_async.patch
+ msg2 "Patching..."
+ patch -p0 -i adapter_async.patch
+ msg2 "Done!"
+}
+
build() {
cd "$srcdir/$_pkgname-$pkgver"
chmod +x ./configure