summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Kohnert2022-03-13 21:09:08 +0000
committerJan Kohnert2022-03-13 21:09:08 +0000
commit5b364746bd144d9b91dbd1213e5b130c62cbd163 (patch)
treea074e57d2eabb32f8e06f3c5204dbbb63a9b17b6
parentbd9ac79b0310770af1a3d4af05d28446744188cd (diff)
downloadaur-5b364746bd144d9b91dbd1213e5b130c62cbd163.tar.gz
Resolve "Version bump 2.25.0"
-rw-r--r--.SRCINFO6
-rw-r--r--.gitlab-ci.yml39
-rw-r--r--PKGBUILD4
3 files changed, 14 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2013b342650b..d96ef69b0d16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eccodes
pkgdesc = ECMWF decoding library for GRIB, BUFR and GTS
- pkgver = 2.24.2
+ pkgver = 2.25.0
pkgrel = 1
url = https://software.ecmwf.int/wiki/display/ECC/ecCodes+Home
arch = i686
@@ -12,9 +12,9 @@ pkgbase = eccodes
depends = netcdf
conflicts = grib_api
conflicts = libbufr-ecmwf
- source = eccodes-2.24.2-Source.tar.gz::https://confluence.ecmwf.int/download/attachments/45757960/eccodes-2.24.2-Source.tar.gz?api=v2
+ source = eccodes-2.25.0-Source.tar.gz::https://confluence.ecmwf.int/download/attachments/45757960/eccodes-2.25.0-Source.tar.gz?api=v2
source = http://download.ecmwf.org/test-data/eccodes/eccodes_test_data.tar.gz
- sha512sums = 6b8ff6dc5e5cc1d27143f9d988f9e23b8ce0a7daf07afa3f0a1abe1670ef8167342080c0b023d85d6061327b172a567e711250c546df69cd2b32830fb802f610
+ sha512sums = b6c675e9bb7377120ae0eb5f1601c3980925b78f240aa26e46cf50ce0d64c5566a4191c83b2ca6ab11fcbcadb70bad1f2c4e188adc245dcf2237292bd359078d
sha512sums = 553eb69f3664c2f847c5ee7a84066e814ef03b3148ae2c13d845891038336daca815673650f1d06efee4f4a1ddaa4326f2ddfbe81d29382e3f25608b249b8d9e
pkgname = eccodes
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 05c3bab26324..a3cc03e024aa 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -2,52 +2,31 @@ include:
- project: "common/gitlab-helper"
ref: master
file: "ci-helper.yml"
- - project: "common/gitlab-helper"
- ref: master
- file: "container-helper.yml"
- - project: "common/gitlab-helper"
- ref: master
- file: "deploy-helper.yml"
-workflow: !reference [.common, workflow]
+workflow: !reference [ .common, workflow ]
variables:
PKG_NAME: "eccodes"
stages:
- - prepareBuild
+ - containerize
- build
- test
- deploy
-docker-build-and-test:
- stage: prepareBuild
- extends: .container-build-and-push
- variables: !reference [.arch-build-and-test, variables]
+container-build-and-test:
+ extends: .arch-containerize
needs: []
build-eccodes:
- stage: build
- image: !reference [.arch-build-and-test, variables, IMAGE_NAME]
+ extends: .arch-build
needs:
- - job: "docker-build-and-test"
+ - job: "container-build-and-test"
artifacts: no
- artifacts: !reference [.arch-build-and-test, artifacts]
- script:
- - !reference [.arch-build, script]
-
+
test-eccodes:
- stage: test
- image: !reference [.arch-build-and-test, variables, IMAGE_NAME]
+ extends: .arch-test
needs: ["build-eccodes"]
- script:
- - !reference [.arch-test, script]
deploy-eccodes:
- stage: deploy
- extends: .git-ssh-push-remote
- variables: !reference [.arch-deploy, variables]
- before_script:
- - !reference [.arch-deploy, before_script]
- rules:
- - !reference [.arch-deploy, rules]
+ extends: .arch-deploy
diff --git a/PKGBUILD b/PKGBUILD
index a8c4972f6c72..56a06d4f2d2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: "Jan Kohnert <bughunter@jan-kohnert.de"
# Contributor: Graziano Giuliani <graziano.giuliani@poste.it>
pkgname=eccodes
-pkgver=2.24.2
+pkgver=2.25.0
_attnum=45757960
pkgrel=1
pkgdesc="ECMWF decoding library for GRIB, BUFR and GTS"
@@ -16,7 +16,7 @@ source=(
"http://download.ecmwf.org/test-data/eccodes/eccodes_test_data.tar.gz"
)
sha512sums=(
- "6b8ff6dc5e5cc1d27143f9d988f9e23b8ce0a7daf07afa3f0a1abe1670ef8167342080c0b023d85d6061327b172a567e711250c546df69cd2b32830fb802f610"
+ "b6c675e9bb7377120ae0eb5f1601c3980925b78f240aa26e46cf50ce0d64c5566a4191c83b2ca6ab11fcbcadb70bad1f2c4e188adc245dcf2237292bd359078d"
"553eb69f3664c2f847c5ee7a84066e814ef03b3148ae2c13d845891038336daca815673650f1d06efee4f4a1ddaa4326f2ddfbe81d29382e3f25608b249b8d9e"
)