summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Kohnert2022-02-26 16:51:53 +0000
committerJan Kohnert2022-02-26 16:51:53 +0000
commitbd9ac79b0310770af1a3d4af05d28446744188cd (patch)
tree3633732b70057ccf43d973b12f6b8ba47b73f19c
parent4e43a56b710314cf41de011209ffccd55f8bd1fc (diff)
downloadaur-bd9ac79b0310770af1a3d4af05d28446744188cd.tar.gz
Resolve "Version bump 2.24.2"
-rw-r--r--.SRCINFO6
-rw-r--r--.gitlab-ci.yml68
-rw-r--r--PKGBUILD4
3 files changed, 24 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04ca5741c5ce..2013b342650b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eccodes
pkgdesc = ECMWF decoding library for GRIB, BUFR and GTS
- pkgver = 2.24.0
+ pkgver = 2.24.2
pkgrel = 1
url = https://software.ecmwf.int/wiki/display/ECC/ecCodes+Home
arch = i686
@@ -12,9 +12,9 @@ pkgbase = eccodes
depends = netcdf
conflicts = grib_api
conflicts = libbufr-ecmwf
- source = eccodes-2.24.0-Source.tar.gz::https://confluence.ecmwf.int/download/attachments/45757960/eccodes-2.24.0-Source.tar.gz?api=v2
+ source = eccodes-2.24.2-Source.tar.gz::https://confluence.ecmwf.int/download/attachments/45757960/eccodes-2.24.2-Source.tar.gz?api=v2
source = http://download.ecmwf.org/test-data/eccodes/eccodes_test_data.tar.gz
- sha512sums = cfd1989ff6d733c3053dae75d1951d6ba475dd6a388b6d747c3a87ade3de9a77da8a6954b6a6ea2eb8cfbd3e08aad7a8b12db1561893f8acc2a9041ce7718e24
+ sha512sums = 6b8ff6dc5e5cc1d27143f9d988f9e23b8ce0a7daf07afa3f0a1abe1670ef8167342080c0b023d85d6061327b172a567e711250c546df69cd2b32830fb802f610
sha512sums = 553eb69f3664c2f847c5ee7a84066e814ef03b3148ae2c13d845891038336daca815673650f1d06efee4f4a1ddaa4326f2ddfbe81d29382e3f25608b249b8d9e
pkgname = eccodes
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index af0802f592b2..05c3bab26324 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -1,30 +1,18 @@
include:
- - project: 'common/gitlab-helper'
+ - project: "common/gitlab-helper"
ref: master
- file: 'container-helper.yml'
- - project: 'common/gitlab-helper'
+ file: "ci-helper.yml"
+ - project: "common/gitlab-helper"
ref: master
- file: 'deploy-helper.yml'
-
-variables:
- BUILD_AND_TEST_IMAGE: build_and_test
+ file: "container-helper.yml"
+ - project: "common/gitlab-helper"
+ ref: master
+ file: "deploy-helper.yml"
-workflow:
- rules:
- # don't create pipeline if the commit message starts with WIP
- - if: $CI_COMMIT_MESSAGE =~ /^WIP/
- when: never
- # don't create pipeline if we're merging from master or version branches
- - if: $CI_MERGE_REQUEST_IID && $CI_COMMIT_REF_NAME =~ /^(master|VER_\d+_\d+)$/
- when: never
- - if: $CI_MERGE_REQUEST_IID
- - if: $CI_COMMIT_REF_NAME =~ /^(master|VER_\d+_\d+)$/
- - if: $CI_COMMIT_TAG
- - if: $CI_PIPELINE_SOURCE =~ /^(trigger|pipeline|web|api|merge_request_event)$/
+workflow: !reference [.common, workflow]
-.rules_templates:
- rules:
- - if: &on_master $CI_COMMIT_REF_NAME =~ /^master$/
+variables:
+ PKG_NAME: "eccodes"
stages:
- prepareBuild
@@ -35,49 +23,31 @@ stages:
docker-build-and-test:
stage: prepareBuild
extends: .container-build-and-push
- variables:
- WORKING_DIR: ${CI_PROJECT_DIR}
- DOCKERFILE_NAME: "Dockerfile.build_and_test"
- IMAGE_NAME: ${CI_REGISTRY_IMAGE}/${BUILD_AND_TEST_IMAGE}:${CI_COMMIT_REF_NAME}
- BUILD_ARGS: REGISTRY=${CI_REGISTRY}
+ variables: !reference [.arch-build-and-test, variables]
needs: []
build-eccodes:
stage: build
- image: ${CI_REGISTRY_IMAGE}/${BUILD_AND_TEST_IMAGE}:${CI_COMMIT_REF_NAME}
+ image: !reference [.arch-build-and-test, variables, IMAGE_NAME]
needs:
- job: "docker-build-and-test"
artifacts: no
- artifacts:
- name: "${CI_JOB_NAME}-${CI_COMMIT_REF_NAME}"
- expire_in: 1 day
- paths:
- - eccodes*.pkg.tar.zst
+ artifacts: !reference [.arch-build-and-test, artifacts]
script:
- # We istalled only depends in the build-and-test image,
- # build-depends need to installed here, so we're able to check
- # the installed package is not dependent on any of the build libs/packages
- - makepkg -s --noconfirm
+ - !reference [.arch-build, script]
test-eccodes:
stage: test
- image: ${CI_REGISTRY_IMAGE}/${BUILD_AND_TEST_IMAGE}:${CI_COMMIT_REF_NAME}
+ image: !reference [.arch-build-and-test, variables, IMAGE_NAME]
needs: ["build-eccodes"]
script:
- # Try to install package
- - sudo pacman -U --noconfirm eccodes*.pkg.tar.zst
- # Recommended checks
- - namcap -m PKGBUILD
- - namcap -m eccodes*.pkg.tar.zst
+ - !reference [.arch-test, script]
deploy-eccodes:
stage: deploy
extends: .git-ssh-push-remote
- variables:
- REMOTE_HOST: "aur.archlinux.org"
- REMOTE_USER: "aur"
- REMOTE_REPOSITORY: "eccodes.git"
+ variables: !reference [.arch-deploy, variables]
before_script:
- - echo "Uploading to AUR..."
+ - !reference [.arch-deploy, before_script]
rules:
- - if: *on_master
+ - !reference [.arch-deploy, rules]
diff --git a/PKGBUILD b/PKGBUILD
index f6959f341739..a8c4972f6c72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: "Jan Kohnert <bughunter@jan-kohnert.de"
# Contributor: Graziano Giuliani <graziano.giuliani@poste.it>
pkgname=eccodes
-pkgver=2.24.0
+pkgver=2.24.2
_attnum=45757960
pkgrel=1
pkgdesc="ECMWF decoding library for GRIB, BUFR and GTS"
@@ -16,7 +16,7 @@ source=(
"http://download.ecmwf.org/test-data/eccodes/eccodes_test_data.tar.gz"
)
sha512sums=(
- "cfd1989ff6d733c3053dae75d1951d6ba475dd6a388b6d747c3a87ade3de9a77da8a6954b6a6ea2eb8cfbd3e08aad7a8b12db1561893f8acc2a9041ce7718e24"
+ "6b8ff6dc5e5cc1d27143f9d988f9e23b8ce0a7daf07afa3f0a1abe1670ef8167342080c0b023d85d6061327b172a567e711250c546df69cd2b32830fb802f610"
"553eb69f3664c2f847c5ee7a84066e814ef03b3148ae2c13d845891038336daca815673650f1d06efee4f4a1ddaa4326f2ddfbe81d29382e3f25608b249b8d9e"
)