summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Grønlien Pejcoch2019-03-29 14:38:34 +0100
committerMartin Grønlien Pejcoch2019-03-29 14:38:34 +0100
commitd9c2fd72b8c5f726b64cf7ef8592ef503e1db948 (patch)
tree42700164b7919daaa42b8e669f4fba43176e4ef6
parentfe658715ddc3066e681f31abaeea4ff7c3cf9f3a (diff)
downloadaur-d9c2fd72b8c5f726b64cf7ef8592ef503e1db948.tar.gz
Version 4.14.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
-rw-r--r--iostream.patch12
-rw-r--r--python.patch128
4 files changed, 11 insertions, 153 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bf883f70782..bcaeb751db73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ecflow
pkgdesc = ecFlow - workflow manager from ECMWF
- pkgver = 4.13.0
+ pkgver = 4.14.0
pkgrel = 1
url = https://software.ecmwf.int/wiki/display/ECFLOW/Getting+Started+with+ecFlowUI
arch = i686
@@ -10,13 +10,13 @@ pkgbase = ecflow
makedepends = cmake
makedepends = boost
depends = qt5-base
+ depends = qt5-charts
+ depends = qt5-svg
+ depends = python
+ depends = git
conflicts = ecflow-ui
- source = https://software.ecmwf.int/wiki/download/attachments/8650755/ecFlow-4.13.0-Source.tar.gz
- source = python.patch
- source = iostream.patch
- sha256sums = c743896e0ec1d705edd2abf2ee5a47f4b6f7b1818d8c159b521bdff50a403e39
- sha256sums = f957e0f66b3b73df20021a40d3a091071d12b1da83d7bb4d06d8245dbb1678f1
- sha256sums = f3612a4f1a169ccf18a82ba9021fabc9ee52e60554b67ec45cc7637b6a331679
+ source = https://software.ecmwf.int/wiki/download/attachments/8650755/ecFlow-4.14.0-Source.tar.gz
+ sha256sums = d8f10a903456ed94f22e33d838a3dd29e2ac34cbe2f25100789f14a5ab82f2c7
pkgname = ecflow
diff --git a/PKGBUILD b/PKGBUILD
index 61fd665fa60f..1e026a05a568 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Contributor: Martin Grønlien Pejcoch <mpejcoch@gmail.com>
pkgname=ecflow
-pkgver=4.13.0
+pkgver=4.14.0
pkgrel=1
pkgdesc="ecFlow - workflow manager from ECMWF"
arch=(i686 x86_64)
url="https://software.ecmwf.int/wiki/display/ECFLOW/Getting+Started+with+ecFlowUI"
license=('APACHE')
groups=(science)
-depends=(qt5-base)
+depends=(qt5-base qt5-charts qt5-svg python git)
makedepends=(cmake boost)
provides=()
conflicts=(ecflow-ui)
@@ -15,14 +15,12 @@ replaces=()
backup=()
options=()
install=
-source=(https://software.ecmwf.int/wiki/download/attachments/8650755/ecFlow-${pkgver}-Source.tar.gz python.patch iostream.patch)
+source=(https://software.ecmwf.int/wiki/download/attachments/8650755/ecFlow-${pkgver}-Source.tar.gz)
noextract=()
-sha256sums=('c743896e0ec1d705edd2abf2ee5a47f4b6f7b1818d8c159b521bdff50a403e39' 'f957e0f66b3b73df20021a40d3a091071d12b1da83d7bb4d06d8245dbb1678f1' 'f3612a4f1a169ccf18a82ba9021fabc9ee52e60554b67ec45cc7637b6a331679')
+sha256sums=('d8f10a903456ed94f22e33d838a3dd29e2ac34cbe2f25100789f14a5ab82f2c7')
prepare() {
cd ecFlow-${pkgver}-Source
- patch --verbose -Np1 -i "${srcdir}/python.patch"
- patch --verbose -Np1 -i "${srcdir}/iostream.patch"
}
build() {
diff --git a/iostream.patch b/iostream.patch
deleted file mode 100644
index c934f7a2b816..000000000000
--- a/iostream.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/Base/src/cts/CtsCmdRegistry.cpp b/Base/src/cts/CtsCmdRegistry.cpp
-index b824af3..8451d3d 100644
---- a/Base/src/cts/CtsCmdRegistry.cpp
-+++ b/Base/src/cts/CtsCmdRegistry.cpp
-@@ -11,6 +11,7 @@
- // nor does it submit to any jurisdiction.
- //
- /////////1/////////2/////////3/////////4/////////5/////////6/////////7/////////8
-+#include <iostream>
- #include <boost/make_shared.hpp>
- #include "CtsCmdRegistry.hpp"
- #include "ClientToServerCmd.hpp"
diff --git a/python.patch b/python.patch
deleted file mode 100644
index 848aab1e1825..000000000000
--- a/python.patch
+++ /dev/null
@@ -1,128 +0,0 @@
-diff --git a/Pyext/CMakeLists.txt b/Pyext/CMakeLists.txt
-index 790822c..83f9c0b 100644
---- a/Pyext/CMakeLists.txt
-+++ b/Pyext/CMakeLists.txt
-@@ -40,99 +40,28 @@ include_directories(
- ../CSim/src
- )
-
--message( STATUS " CMAKE_VERSION : ${CMAKE_VERSION}, need cmake version >= 3.12.0 to build ecflow python3 extension" )
--if(${CMAKE_VERSION} VERSION_LESS "3.12.0")
-- # We only support python2 extension for cmake less 3.12.0
-- # cmake 3.12.0 or greater allows multiple boost python libs & hence multiple extensions to be built
-- # Using -DPYTHON_EXECUTABLE=/usr/local/apps/python3/3.6.5-01/bin/python3 is not suffcient as the wrong(python2) libs are found
-- ecbuild_find_python( VERSION 2.6 REQUIRED )
-- message( STATUS " PYTHON_FOUND : ${PYTHON_FOUND}" )
-- message( STATUS " PYTHONINTERP_FOUND : ${PYTHONINTERP_FOUND}" )
-- message( STATUS " PYTHONLIBS_FOUND : ${PYTHONLIBS_FOUND}" )
-- message( STATUS " PYTHON_VERSION_STRING : ${PYTHON_VERSION_STRING}" )
-- message( STATUS " PYTHON_VERSION_MAJOR : ${PYTHON_VERSION_MAJOR}" )
-- message( STATUS " PYTHON_VERSION_MINOR : ${PYTHON_VERSION_MINOR}" )
-- message( STATUS " PYTHON_VERSION_PATCH : ${PYTHON_VERSION_PATCH}" )
-- message( STATUS " PYTHON_CONFIG_EXECUTABLE : ${PYTHON_CONFIG_EXECUTABLE}" )
-- message( STATUS " PYTHON_EXECUTABLE : ${PYTHON_EXECUTABLE}" )
-- message( STATUS " PYTHON_INCLUDE_DIRS : ${PYTHON_INCLUDE_DIRS}" )
-- message( STATUS " PYTHON_LIBRARIES : ${PYTHON_LIBRARIES}" )
-- if (${PYTHON_VERSION_MAJOR} EQUAL 3)
-- ecbuild_error("Need cmake version >= 3.12.0 to build ecflow python3 extension, current cmake version is ${CMAKE_VERSION}")
-- endif()
-- find_package( Boost ${ECFLOW_BOOST_VERSION} REQUIRED COMPONENTS python )
-- add_subdirectory( python2 )
--else()
-- # ======================================================================================
-- # Attempt to build both python2 and python3 ecflow extension, depending on what is found
-- # this assumes cmake 3.12.0 min, which added support for boost python2 and python3
-- # ======================================================================================
-- find_package(Python2 COMPONENTS Interpreter Development)
-- message( STATUS " Python2_FOUND : ${Python2_FOUND}" )
-- if (Python2_FOUND)
-- if ( NOT Python2_LIBRARIES )
-- ecbuild_error("ecflow python extension is enabled, but python2 libraries not found")
-- endif()
--
-- # *****************************************************************************************
-- # Although we have found python2 it could be that *ONLY* python3 was module loaded
-- # Otherwise will build for python2 and test with python3 interpreter
-- # *****************************************************************************************
-- ecbuild_find_python( VERSION 2.6 REQUIRED ) # if not included iterpreter not found ?
-- if ( ${PYTHON_VERSION_MAJOR} EQUAL 2)
-- message( STATUS " Python2_Interpreter_FOUND : ${Python2_Interpreter_FOUND}" )
-- message( STATUS " Python2_EXECUTABLE : ${Python2_EXECUTABLE}" )
-- message( STATUS " Python2_STDLIB : ${Python2_STDLIB} Standard platform independent installation directory" )
-- message( STATUS " Python2_STDARCH : ${Python2_STDARCH} Standard platform dependent installation directory." )
-- message( STATUS " Python2_Development_FOUND : ${Python2_Development_FOUND}" )
-- message( STATUS " Python2_INCLUDE_DIRS : ${Python2_INCLUDE_DIRS}" )
-- message( STATUS " Python2_LIBRARIES : ${Python2_LIBRARIES}" )
-- message( STATUS " Python2_LIBRARY_DIRS : ${Python2_LIBRARY_DIRS}" )
-- message( STATUS " Python2_VERSION : ${Python2_VERSION}" )
-- message( STATUS " Python2_VERSION_MAJOR : ${Python2_VERSION_MAJOR}" )
-- message( STATUS " Python2_VERSION_MINOR : ${Python2_VERSION_MINOR}" )
-- message( STATUS " Python2_VERSION_PATCH : ${Python2_VERSION_PATCH}" )
--
-- message( STATUS " PYTHON_FOUND : ${PYTHON_FOUND}" )
-- message( STATUS " PYTHONINTERP_FOUND : ${PYTHONINTERP_FOUND}" )
-- message( STATUS " PYTHONLIBS_FOUND : ${PYTHONLIBS_FOUND}" )
-- message( STATUS " PYTHON_VERSION_STRING : ${PYTHON_VERSION_STRING}" )
-- message( STATUS " PYTHON_VERSION_MAJOR : ${PYTHON_VERSION_MAJOR}" )
-- message( STATUS " PYTHON_VERSION_MINOR : ${PYTHON_VERSION_MINOR}" )
-- message( STATUS " PYTHON_VERSION_PATCH : ${PYTHON_VERSION_PATCH}" )
-- message( STATUS " PYTHON_CONFIG_EXECUTABLE : ${PYTHON_CONFIG_EXECUTABLE}" )
-- message( STATUS " PYTHON_EXECUTABLE : ${PYTHON_EXECUTABLE}" )
-- message( STATUS " PYTHON_INCLUDE_DIRS : ${PYTHON_INCLUDE_DIRS}" )
-- message( STATUS " PYTHON_LIBRARIES : ${PYTHON_LIBRARIES}" )
--
-- find_package( Boost ${ECFLOW_BOOST_VERSION} REQUIRED COMPONENTS python )
-- add_subdirectory( python2 )
-- endif()
-- endif()
--
-- find_package(Python3 COMPONENTS Interpreter Development)
-- message( STATUS " Python3_FOUND : ${Python3_FOUND}" )
-- if (Python3_FOUND)
-- message( STATUS " Python3_Interpreter_FOUND : ${Python3_Interpreter_FOUND}" )
-- message( STATUS " Python3_EXECUTABLE : ${Python3_EXECUTABLE}" )
-- message( STATUS " Python3_STDLIB : ${Python3_STDLIB} Standard platform independent installation directory" )
-- message( STATUS " Python3_STDARCH : ${Python3_STDARCH} Standard platform dependent installation directory." )
-- message( STATUS " Python3_Development_FOUND : ${Python3_Development_FOUND}" )
-- message( STATUS " Python3_INCLUDE_DIRS : ${Python3_INCLUDE_DIRS}" )
-- message( STATUS " Python3_LIBRARIES : ${Python3_LIBRARIES}" )
-- message( STATUS " Python3_LIBRARY_DIRS : ${Python3_LIBRARY_DIRS}" )
-- message( STATUS " Python3_VERSION : ${Python3_VERSION}" )
-- message( STATUS " Python3_VERSION_MAJOR : ${Python3_VERSION_MAJOR}" )
-- message( STATUS " Python3_VERSION_MINOR : ${Python3_VERSION_MINOR}" )
-- message( STATUS " Python3_VERSION_PATCH : ${Python3_VERSION_PATCH}" )
--
-- if ( NOT Python3_LIBRARIES )
-- ecbuild_error("ecflow python extension is enabled, but python3 libraries not found")
-- endif()
--
-- ecbuild_find_python( VERSION ${Python3_VERSION} REQUIRED )
--
-- find_package( Boost ${ECFLOW_BOOST_VERSION} REQUIRED COMPONENTS python3 )
-- add_subdirectory( python3 )
-- endif()
-+find_package(Python3 COMPONENTS Interpreter Development)
-+message( STATUS " Python3_FOUND : ${Python3_FOUND}" )
-+if (Python3_FOUND)
-+ message( STATUS " Python3_Interpreter_FOUND : ${Python3_Interpreter_FOUND}" )
-+ message( STATUS " Python3_EXECUTABLE : ${Python3_EXECUTABLE}" )
-+ message( STATUS " Python3_STDLIB : ${Python3_STDLIB} Standard platform independent installation directory" )
-+ message( STATUS " Python3_STDARCH : ${Python3_STDARCH} Standard platform dependent installation directory." )
-+ message( STATUS " Python3_Development_FOUND : ${Python3_Development_FOUND}" )
-+ message( STATUS " Python3_INCLUDE_DIRS : ${Python3_INCLUDE_DIRS}" )
-+ message( STATUS " Python3_LIBRARIES : ${Python3_LIBRARIES}" )
-+ message( STATUS " Python3_LIBRARY_DIRS : ${Python3_LIBRARY_DIRS}" )
-+ message( STATUS " Python3_VERSION : ${Python3_VERSION}" )
-+ message( STATUS " Python3_VERSION_MAJOR : ${Python3_VERSION_MAJOR}" )
-+ message( STATUS " Python3_VERSION_MINOR : ${Python3_VERSION_MINOR}" )
-+ message( STATUS " Python3_VERSION_PATCH : ${Python3_VERSION_PATCH}" )
-+
-+ if ( NOT Python3_LIBRARIES )
-+ ecbuild_error("ecflow python extension is enabled, but python3 libraries not found")
-+ endif()
-+
-+ ecbuild_find_python( VERSION ${Python3_VERSION} REQUIRED )
-+
-+ find_package( Boost ${ECFLOW_BOOST_VERSION} REQUIRED COMPONENTS python37 )
-+ add_subdirectory( python3 )
- endif()