summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Giammarchi2016-10-16 13:43:00 +0100
committerAndrea Giammarchi2016-10-16 13:43:00 +0100
commit2c9389f1ce8d06fedf6184dc3e8b0349c6e083b8 (patch)
tree63a4b5a80fff86dc8376db55740a9de05f1e00ad
downloadaur-2c9389f1ce8d06fedf6184dc3e8b0349c6e083b8.tar.gz
echomd first AUR version
-rw-r--r--.SRCINFO13
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD20
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93cee1d9d70c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = echomd
+ pkgdesc = A markdown like conversion tool for shell terminals.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/WebReflection/echomd
+ arch = any
+ license = MIT
+ depends = perl
+ source = https://webreflection.github.io/echomd/archive/echomd-0.1.1.tar.gz
+ md5sums = 87b47e9a69fb9c05aca7bb84ba9ef1fb
+
+pkgname = echomd
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..008e3324c083
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+The MIT License (MIT)
+Copyright (c) 2016 Andrea Giammarchi - @WebReflection
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom
+the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
+DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH
+THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fbe3ec12f0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Andrea Giammarchi <andrea.giammarchi@gmail.com>
+pkgname=echomd
+pkgrel=1
+pkgver=0.1.1
+pkgdesc="A markdown like conversion tool for shell terminals."
+arch=('any')
+url="https://github.com/WebReflection/echomd"
+license=('MIT')
+depends=('perl')
+source=(https://webreflection.github.io/echomd/archive/$pkgname-$pkgver.tar.gz)
+md5sums=('87b47e9a69fb9c05aca7bb84ba9ef1fb')
+
+package() {
+
+ cd "${srcdir}/${pkgname}"
+
+ # Install program file
+ install -Dm755 ${pkgname}.pl "${pkgdir}/usr/bin/${pkgname}"
+
+}