summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2018-03-07 21:57:45 +0800
committerJingbei Li2018-03-07 21:57:45 +0800
commit2a3ea91fc5f35c0644a6a667f53d3086d4361731 (patch)
tree1726a823b90594ea747e5d7ab02b666553a6dccd
parent0da83c10e3647d9b51abde2eaa3f10e197345930 (diff)
downloadaur-2a3ea91fc5f35c0644a6a667f53d3086d4361731.tar.gz
fix plantuml issue
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD7
3 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e88c0fb85255..90e7e6f35c08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jan 16 07:06:56 UTC 2018
+# Wed Mar 7 13:57:41 UTC 2018
pkgbase = eclim
pkgdesc = Brings Eclipse functionality to Vim
pkgver = 2.7.1
- pkgrel = 1
+ pkgrel = 2
url = http://eclim.org/
install = eclim.install
arch = i686
@@ -11,6 +11,7 @@ pkgbase = eclim
license = GPL3
makedepends = apache-ant
makedepends = python2-sphinx
+ makedepends = python2-docutils
makedepends = groovy
depends = vim
depends = eclipse
diff --git a/.gitignore b/.gitignore
index 8153befe1650..44d8b55a9e9f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+*/
*.sw*
*.log
*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
index 1105237cb15c..74c3c9306667 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor: Andrea Fagiani <andfagiani_at_gmail_dot_com>
pkgname=eclim
pkgver=2.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="Brings Eclipse functionality to Vim"
url="http://eclim.org/"
license=('GPL3')
arch=(i686 x86_64)
depends=('vim' 'eclipse' 'java-environment')
-makedepends=('apache-ant' 'python2-sphinx' 'groovy')
+makedepends=('apache-ant' 'python2-sphinx' 'python2-docutils' 'groovy')
optdepends=('eclipse-pdt: Eclipse PHP Development Tools support'
'eclipse-cdt: Eclipse C/C++ Plugin support'
'eclipse-dltk-core: Eclipse Dynamic Languagues Toolkit support'
@@ -33,6 +33,9 @@ prepare() {
source /etc/profile.d/apache-ant.sh
chmod +x org.eclim/nailgun/configure bin/sphinx
+
+ # Sphinx 1.6 => 1.7 compatibility issue
+ sed 's|sphinx.util.compat|docutils.parsers.rst|' -i doc/extension/plantuml.py
}
build() {