summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Moffa2021-08-21 15:37:07 +0200
committerMattia Moffa2021-08-21 15:37:07 +0200
commit443eabd73fff0af6100b94ce428a4d06b9eec975 (patch)
tree9b8277d5875321b837ce8573940f9d70a362939c
parentd5020256d08f7807b55a7717343e9fe2fc25e10e (diff)
downloadaur-443eabd73fff0af6100b94ce428a4d06b9eec975.tar.gz
Fixed icon copying with AUR_BUILD=false
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c8339081c9e..48fe48d85613 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -29,3 +29,9 @@ pkgname = eclipse-jee
pkgname = eclipse-cpp
pkgname = eclipse-php
+
+pkgname = eclipse-common
+ pkgdesc = Highly extensible IDE (common files)
+ depends = java-environment>=8
+ depends = webkit2gtk
+ depends = unzip
diff --git a/PKGBUILD b/PKGBUILD
index 3a420fdf813a..c72913c963c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Marco Crosio <marco.crosio@gmail.com>
# Toggle this if you're building outside of the AUR, for a repo.
-AUR_BUILD=true
+AUR_BUILD=false
# Edit to enable/disable packages to build
pkgname=(eclipse-{java,jee,cpp,php})
@@ -55,7 +55,6 @@ noextract=()
for _pkg in ${pkgname[@]}; do
_src=$(_sourcename $_pkg) || continue
- #source_x86_64+=(http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/$_release/$_src)
source_x86_64+=("$_src::https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/$_release/$_src&r=1")
sha512sums_x86_64+=("${_sha512sums_x86_64["$_pkg"]}")
noextract+=($_src)
@@ -74,7 +73,7 @@ prepare() {
build() {
if [ "$AUR_BUILD" = false ]; then
- mkdir eclipse-common/dropins
+ mkdir -p eclipse-common/dropins
touch eclipse-common/dropins/.keep
./commonify --identical ${pkgname[@]}
fi
@@ -103,7 +102,7 @@ _package() {
modeling ) variant="Modeling" ;;
parallel ) variant="Parallel" ;;
scout ) variant="Scout" ;;
- * ) return 1 ;;
+ * ) return ${1#eclipse-} ;;
esac
pkgdesc+=" for $variant"