summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarson Black2020-09-22 14:52:52 -0400
committerCarson Black2020-09-22 14:52:52 -0400
commit5c8b138d4feb8d26468123dfa3f33f88be171a5b (patch)
treed752bfeb73391a7b26103befcb7623c8a8582375
parenteac61264a7af69762955d2460ed43f0ebf453b77 (diff)
downloadaur-5c8b138d4feb8d26468123dfa3f33f88be171a5b.tar.gz
fix: Address issue with icons
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c4441401b4c..038930d150b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = eclipse
pkgdesc = Highly extensible IDE
pkgver = 4.17
- pkgrel = 2
+ pkgrel = 3
epoch = 2
url = https://eclipse.org
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 4c6c024e85d3..f38a794a5d0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ if [ "$AUR_BUILD" = false ]; then
pkgname+=(eclipse-common)
fi
pkgver=4.17
-pkgrel=2
+pkgrel=3
epoch=2
_release=2020-09/R
pkgdesc="Highly extensible IDE"
@@ -122,5 +122,10 @@ END
install -Dm644 eclipse-common/plugins/org.eclipse.platform_*/eclipse$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x$i/apps/eclipse.png"
done
+ else
+ for i in 16 22 24 32 48 64 128 256 512 1024; do
+ install -Dm644 $1/plugins/org.eclipse.platform_*/eclipse$i.png \
+ "$pkgdir/usr/share/icons/hicolor/${i}x$i/apps/eclipse.png"
+ done
fi
}