summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarson Black2020-05-02 11:18:32 -0400
committerCarson Black2020-05-02 11:18:32 -0400
commit6bf8b0943d258d882b71a3c71be4cbd42faa6b33 (patch)
tree23841c36a83e28dd71eebcc6b14de927b7baf612
parentdae7f3412446114bc069580b5648cd821fde5fe4 (diff)
downloadaur-6bf8b0943d258d882b71a3c71be4cbd42faa6b33.tar.gz
Fix source URLs
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD4
3 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96be1a86c545..6067bb01a42e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = eclipse
pkgdesc = Highly extensible IDE
pkgver = 4.15
- pkgrel = 3
+ pkgrel = 4
url = https://eclipse.org
arch = x86_64
license = EPL
makedepends = python3
noextract = eclipse-java-2020-03-R-linux-gtk-x86_64.tar.gz
- noextract = eclipse-jee-2020-03-R-linux-gtk-x86_64.tar.gz
- noextract = eclipse-cpp-2020-03-R-linux-gtk-x86_64.tar.gz
+ noextract = eclipse-jee-2020-03-R-incubation-linux-gtk-x86_64.tar.gz
+ noextract = eclipse-cpp-2020-03-R-incubation-linux-gtk-x86_64.tar.gz
noextract = eclipse-php-2020-03-R-linux-gtk-x86_64.tar.gz
- noextract = eclipse-javascript-2020-03-R-linux-gtk-x86_64.tar.gz
+ noextract = eclipse-javascript-2020-03-R-incubation-linux-gtk-x86_64.tar.gz
noextract = eclipse-rust-2020-03-R-incubation-linux-gtk-x86_64.tar.gz
source = commonify
sha256sums = a68cccdf182449dfb4aef595ab26fe6542902421aef42a79672483865cbbd0ea
source_x86_64 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/2020-03/R/eclipse-java-2020-03-R-linux-gtk-x86_64.tar.gz
- source_x86_64 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/2020-03/R/eclipse-jee-2020-03-R-linux-gtk-x86_64.tar.gz
- source_x86_64 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/2020-03/R/eclipse-cpp-2020-03-R-linux-gtk-x86_64.tar.gz
+ source_x86_64 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/2020-03/R/eclipse-jee-2020-03-R-incubation-linux-gtk-x86_64.tar.gz
+ source_x86_64 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/2020-03/R/eclipse-cpp-2020-03-R-incubation-linux-gtk-x86_64.tar.gz
source_x86_64 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/2020-03/R/eclipse-php-2020-03-R-linux-gtk-x86_64.tar.gz
- source_x86_64 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/2020-03/R/eclipse-javascript-2020-03-R-linux-gtk-x86_64.tar.gz
+ source_x86_64 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/2020-03/R/eclipse-javascript-2020-03-R-incubation-linux-gtk-x86_64.tar.gz
source_x86_64 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/2020-03/R/eclipse-rust-2020-03-R-incubation-linux-gtk-x86_64.tar.gz
sha256sums_x86_64 = eea78b2daab7c5d3e11cd86d0782023a05f7e173265f470536357ef97cd31a29
sha256sums_x86_64 = a012ad5dd54c344aff66b82f0ed37b54002e727566c7d786d0d60f96b1117c38
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5285db6860a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.part
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index d8e953f60a17..44e2208b922d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgbase=eclipse
pkgname=(eclipse-{common,java,jee,cpp,php,javascript,rust})
pkgver=4.15
-pkgrel=3
+pkgrel=4
_release=2020-03/R
pkgdesc="Highly extensible IDE"
license=(EPL)
@@ -28,7 +28,7 @@ sha256sums_x86_64=('eea78b2daab7c5d3e11cd86d0782023a05f7e173265f470536357ef97cd3
_sourcename() {
case $1 in
eclipse-common) return 1 ;;
- eclipse-rust ) echo $1-${_release//\//-}-incubation-linux-gtk-x86_64.tar.gz ;;
+ eclipse-rust|eclipse-cpp|eclipse-jee|eclipse-javascript) echo $1-${_release//\//-}-incubation-linux-gtk-x86_64.tar.gz ;;
* ) echo $1-${_release//\//-}-linux-gtk-x86_64.tar.gz ;;
esac
}