summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-08-27 19:25:38 +0300
committervlad2015-08-27 19:25:38 +0300
commit4ce16dba7261987e89648fb711426b751afccfd4 (patch)
tree4a9dd5a790f3d91538d0ebc98091b02f98005a06
parent798c6bc7b06c6ed456ce1d54176d9594bad9fc25 (diff)
downloadaur-4ce16dba7261987e89648fb711426b751afccfd4.tar.gz
fix _dest
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e24d31b324c3..5fdd66b98f86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = eclipse-android
pkgdesc = Eclipse plugin for Android
pkgver = 23.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://developer.android.com/sdk/eclipse-adt.html
arch = any
license = Apache
@@ -9,8 +9,8 @@ pkgbase = eclipse-android
license = EPL
license = LGPL
depends = android-sdk>=r24.1.2
- depends = java-environment>=6
- depends = eclipse>=3.7.2
+ depends = java-environment
+ depends = eclipse>=4.5
depends = eclipse-wtp
options = !strip
source = http://dl.google.com/android/ADT-23.0.6.zip
diff --git a/PKGBUILD b/PKGBUILD
index 59f114c4b752..c2c3c3886c62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Jakub Schmidtke <sjakub-at-gmail-dot-com>
+# Maintainer: Vlad M. <vlad@archlinux.net>
+# Contributor: Jakub Schmidtke <sjakub-at-gmail-dot-com>
# Contributor: Forrest L <cybercyst at gmail com>
# Contributor: Michael P <ptchinster@archlinux.us>
# Contributor: Marcin "eXine" M. <exine@jun.pl>
@@ -10,21 +11,19 @@
pkgname=eclipse-android
pkgver=23.0.6
_sdkver=24.1.2
-pkgrel=1
+pkgrel=2
pkgdesc='Eclipse plugin for Android'
url='https://developer.android.com/sdk/eclipse-adt.html'
license=('Apache' 'BSD' 'EPL' 'LGPL')
arch=('any')
-depends=("android-sdk>=r${_sdkver}" 'java-environment>=6' 'eclipse>=3.7.2' 'eclipse-wtp')
+depends=("android-sdk>=r${_sdkver}" 'java-environment' 'eclipse>=4.5' 'eclipse-wtp')
options=('!strip')
source=("http://dl.google.com/android/ADT-${pkgver}.zip" "LICENSE.kxml2")
sha1sums=('1ce14cf4f6e3bf8e4213dd22cfd14c2237c8c22d'
'c0a96dc032bb53e2921200c85f5cf650e49878e9')
package() {
- _dest="${pkgdir}/usr/share/eclipse/dropins/android/eclipse"
-
- cd "${srcdir}"
+ _dest="${pkgdir}/usr/lib/eclipse/dropins/android/eclipse"
# Features
for _f in features/*.jar; do
@@ -38,5 +37,5 @@ package() {
install -Dm644 "${_p}" "${_dest}/${_p}"
done
- install -D -m644 LICENSE.kxml2 "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.kxml2"
+ install -Dm644 LICENSE.kxml2 "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.kxml2"
}