summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-07-08 15:45:20 +0300
committervlad2015-07-08 15:45:20 +0300
commit798c6bc7b06c6ed456ce1d54176d9594bad9fc25 (patch)
tree96e81abde9925d85e13d0d93bb7d5e92a43b0048
downloadaur-798c6bc7b06c6ed456ce1d54176d9594bad9fc25.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE.kxml220
-rw-r--r--PKGBUILD42
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e24d31b324c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = eclipse-android
+ pkgdesc = Eclipse plugin for Android
+ pkgver = 23.0.6
+ pkgrel = 1
+ url = https://developer.android.com/sdk/eclipse-adt.html
+ arch = any
+ license = Apache
+ license = BSD
+ license = EPL
+ license = LGPL
+ depends = android-sdk>=r24.1.2
+ depends = java-environment>=6
+ depends = eclipse>=3.7.2
+ depends = eclipse-wtp
+ options = !strip
+ source = http://dl.google.com/android/ADT-23.0.6.zip
+ source = LICENSE.kxml2
+ sha1sums = 1ce14cf4f6e3bf8e4213dd22cfd14c2237c8c22d
+ sha1sums = c0a96dc032bb53e2921200c85f5cf650e49878e9
+
+pkgname = eclipse-android
+
diff --git a/LICENSE.kxml2 b/LICENSE.kxml2
new file mode 100644
index 000000000000..089de5ca5fd6
--- /dev/null
+++ b/LICENSE.kxml2
@@ -0,0 +1,20 @@
+Copyright (c) 2002,2003, Stefan Haustein, Oberhausen, Rhld., Germany
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or
+sell copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+IN THE SOFTWARE.
+ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59f114c4b752
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jakub Schmidtke <sjakub-at-gmail-dot-com>
+# Contributor: Forrest L <cybercyst at gmail com>
+# Contributor: Michael P <ptchinster@archlinux.us>
+# Contributor: Marcin "eXine" M. <exine@jun.pl>
+# Contributor: Artyom Smirnov <smirnoffjr@gmail.com>
+# Contributor: Ashok `ScriptDevil` Gautham <ScriptDevil@gmail.com>
+# Contributor: Laszlo Papp <djszapi2 at gmail com>
+# Contributor: Antonio Santos <asantos at gmail dot com>
+
+pkgname=eclipse-android
+pkgver=23.0.6
+_sdkver=24.1.2
+pkgrel=1
+pkgdesc='Eclipse plugin for Android'
+url='https://developer.android.com/sdk/eclipse-adt.html'
+license=('Apache' 'BSD' 'EPL' 'LGPL')
+arch=('any')
+depends=("android-sdk>=r${_sdkver}" 'java-environment>=6' 'eclipse>=3.7.2' 'eclipse-wtp')
+options=('!strip')
+source=("http://dl.google.com/android/ADT-${pkgver}.zip" "LICENSE.kxml2")
+sha1sums=('1ce14cf4f6e3bf8e4213dd22cfd14c2237c8c22d'
+ 'c0a96dc032bb53e2921200c85f5cf650e49878e9')
+
+package() {
+ _dest="${pkgdir}/usr/share/eclipse/dropins/android/eclipse"
+
+ cd "${srcdir}"
+
+ # Features
+ for _f in features/*.jar; do
+ _dir="${_dest}/${_f/.jar}"
+ mkdir -p "${_dir}"
+ bsdtar -xf "${_f}" -C "${_dir}"
+ done
+
+ # Plugins
+ for _p in plugins/*.jar; do
+ install -Dm644 "${_p}" "${_dest}/${_p}"
+ done
+
+ install -D -m644 LICENSE.kxml2 "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.kxml2"
+}