summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rosenstrauch2017-02-08 16:12:57 -0500
committerDavid Rosenstrauch2017-02-08 16:12:57 -0500
commitbe716b2ea414087f2f6eaeb442e52519dac4917a (patch)
tree56beca3cc489e2e23d5e92d67233af777667c45a
downloadaur-eclipse-antlr4-runtime.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2861fa31ecf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = eclipse-antlr4-runtime
+ pkgdesc = Support for antlr parser generator in Eclipse
+ pkgver = 4.5.2
+ pkgrel = 1
+ url = https://github.com/boothen/Json-Eclipse-Plugin
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = eclipse
+ noextract = org.antlr.v4_4.5.2.jar
+ noextract = org.antlr.antlr4-runtime-osgi_4.5.2.1.jar
+ noextract = org.antlr.antlr4-runtime-osgi.source_4.5.2.1.jar
+ source = http://boothen.github.io/Json-Eclipse-Plugin/features/org.antlr.v4_4.5.2.jar
+ source = http://boothen.github.io/Json-Eclipse-Plugin/plugins/org.antlr.antlr4-runtime-osgi_4.5.2.1.jar
+ source = http://boothen.github.io/Json-Eclipse-Plugin/plugins/org.antlr.antlr4-runtime-osgi.source_4.5.2.1.jar
+ md5sums = 58d3f0a6bf3e8d709bbff19416fe37e3
+ md5sums = 8116b492724169f01a9417f75721221f
+ md5sums = 4e12a9a6ebc172027ed4e0a2f1205f16
+
+pkgname = eclipse-antlr4-runtime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe2ec49a90e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Jonathan Wiersma <archaur at jonw dot org>
+# Maintainer: David Rosenstrauch <darose@darose.net>
+
+pkgname=eclipse-antlr4-runtime
+pkgver=4.5.2
+pkgrel=1
+pkgdesc="Support for antlr parser generator in Eclipse"
+arch=('i686' 'x86_64')
+url="https://github.com/boothen/Json-Eclipse-Plugin"
+license=('BSD')
+depends=("eclipse")
+noextract=(
+ org.antlr.v4_4.5.2.jar
+ org.antlr.antlr4-runtime-osgi_4.5.2.1.jar
+ org.antlr.antlr4-runtime-osgi.source_4.5.2.1.jar
+)
+source=(
+ "http://boothen.github.io/Json-Eclipse-Plugin/features/org.antlr.v4_4.5.2.jar"
+ "http://boothen.github.io/Json-Eclipse-Plugin/plugins/org.antlr.antlr4-runtime-osgi_4.5.2.1.jar"
+ "http://boothen.github.io/Json-Eclipse-Plugin/plugins/org.antlr.antlr4-runtime-osgi.source_4.5.2.1.jar"
+)
+md5sums=(
+ '58d3f0a6bf3e8d709bbff19416fe37e3'
+ '8116b492724169f01a9417f75721221f'
+ '4e12a9a6ebc172027ed4e0a2f1205f16'
+)
+
+package() {
+ install -d "$pkgdir/usr/lib/eclipse/dropins/${pkgname#eclipse-}/eclipse/features"
+ install -m644 "$srcdir/org.antlr.v4_4.5.2.jar" \
+ "$pkgdir/usr/lib/eclipse/dropins/${pkgname#eclipse-}/eclipse/features"
+
+ install -d "$pkgdir/usr/lib/eclipse/dropins/${pkgname#eclipse-}/eclipse/plugins"
+ install -m644 "$srcdir/org.antlr.antlr4-runtime-osgi_4.5.2.1.jar" \
+ "$pkgdir/usr/lib/eclipse/dropins/${pkgname#eclipse-}/eclipse/plugins"
+ install -m644 "$srcdir/org.antlr.antlr4-runtime-osgi.source_4.5.2.1.jar" \
+ "$pkgdir/usr/lib/eclipse/dropins/${pkgname#eclipse-}/eclipse/plugins"
+}