summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Aladin2016-02-07 21:55:11 +0300
committerGeorge Aladin2016-02-07 21:55:11 +0300
commit90b6193e2b40a3cf1992633ba55d52acb68268c2 (patch)
tree6173c2d1b9e8f6adacf4dd799d43456b69b049be
parent08dfbc2462a68fa8eeecc7b40615b1685de82d1d (diff)
downloadaur-90b6193e2b40a3cf1992633ba55d52acb68268c2.tar.gz
edit path,fix depending
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b52f5cb67cbe..fb81d6780fa8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
+# Generated by mksrcinfo v8
+# Sun Feb 7 18:48:57 UTC 2016
pkgbase = eclipse-avr
pkgdesc = AVR Plugin for Eclipse
pkgver = 2.4.2
- pkgrel = 1
+ pkgrel = 2
url = http://avr-eclipse.sourceforge.net/wiki/index.php/The_AVR_Eclipse_Plugin
arch = any
license = EPL
- depends = eclipse
- depends = eclipse-cdt
+ depends = eclipse-cpp
depends = avr-gcc
depends = avr-libc
depends = avrdude
diff --git a/PKGBUILD b/PKGBUILD
index 60d129b36e02..cd744cba2bdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Contributor: Doug Newgard <scimmia at archlinux dot info>
# Contributor: Stepan Usatiuk aka stepus53 <stepus53@gmail.com>
# Contributor: Alexsandr Pavlov <kidoz at mail dot ru>
+# Contributor: Sinnamon (George Aladin) <AngleSi at yahoo dot com>
pkgname=eclipse-avr
pkgver=2.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="AVR Plugin for Eclipse"
arch=('any')
url='http://avr-eclipse.sourceforge.net/wiki/index.php/The_AVR_Eclipse_Plugin'
license=('EPL')
-depends=('eclipse' 'eclipse-cdt' 'avr-gcc' 'avr-libc' 'avrdude')
+depends=('eclipse-cpp' 'avr-gcc' 'avr-libc' 'avrdude')
source=("http://downloads.sourceforge.net/project/avr-eclipse/avr-eclipse%20stable%20release/$pkgver/de.innot.avreclipse.p2repository-$pkgver.zip")
sha1sums=('b30145e87629bfbeefd7e47d6ed7397b4204d749')
package() {
cd "$srcdir"
- install -d "$pkgdir/usr/share/eclipse/dropins/avr/eclipse/"{features,plugins}
- install -m644 features/* "$pkgdir/usr/share/eclipse/dropins/avr/eclipse/features/"
- install -m644 plugins/* "$pkgdir/usr/share/eclipse/dropins/avr/eclipse/plugins/"
+ install -d "$pkgdir/usr/lib/eclipse/dropins/avr/eclipse/"{features,plugins}
+ install -m644 features/* "$pkgdir/usr/lib/eclipse/dropins/avr/eclipse/features/"
+ install -m644 plugins/* "$pkgdir/usr/lib/eclipse/dropins/avr/eclipse/plugins/"
}