summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Tsanev2013-06-05 16:57:24 +0300
committerVladimir Tsanev2015-06-21 16:00:55 +0300
commit7ff1352be64e471bc47ec39677c2238218e0ffe9 (patch)
treef02c4b79e9671a2586a96890511ab8bcf9b23fc2
downloadaur-7ff1352be64e471bc47ec39677c2238218e0ffe9.tar.gz
updated to v6.5.0. migrated to aur4
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD37
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba37dc800b23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = eclipse-checkstyle
+ pkgdesc = Checkstyle plugin for Eclipse
+ pkgver = 6.5.0
+ pkgrel = 1
+ url = http://eclipse-cs.sourceforge.net/
+ arch = any
+ license = LGPL
+ depends = eclipse
+ source = http://sourceforge.net/projects/eclipse-cs/files/Eclipse%20Checkstyle%20Plug-in/6.5.0/net.sf.eclipsecs-updatesite_6.5.0.201504121610-bin.zip
+ sha256sums = 02abf1680bdac01a27cbb0cab9a72b9c6015baa41d0b683bbc4485d314a72f07
+
+pkgname = eclipse-checkstyle
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b26d2fb9c880
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.xz
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aef29f31fc55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Vladimir Tsanev <tsachev@gmail.com>
+# Contributor: Alistair Dutton <kelveden at gmail.com>
+
+pkgname=eclipse-checkstyle
+pkgver=6.5.0
+_pkgver_date=201504121610
+pkgrel=1
+pkgdesc="Checkstyle plugin for Eclipse"
+arch=('any')
+url="http://eclipse-cs.sourceforge.net/"
+license=('LGPL')
+depends=('eclipse')
+optdepends=()
+source=("http://sourceforge.net/projects/eclipse-cs/files/Eclipse%20Checkstyle%20Plug-in/${pkgver}/net.sf.eclipsecs-updatesite_${pkgver}.${_pkgver_date}-bin.zip")
+sha256sums=('02abf1680bdac01a27cbb0cab9a72b9c6015baa41d0b683bbc4485d314a72f07')
+
+package() {
+ _dest=${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+
+ cd ${srcdir}
+
+ # Features
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+
+ # Plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
+}