summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commit6bb31c45dbae125304f1a40d184d8281e86c1525 (patch)
tree369a115d98c3d900853112d9038f80f5a1a04cfb
downloadaur-6bb31c45dbae125304f1a40d184d8281e86c1525.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7bd6c8b8dbe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = eclipse-dltk-python
+ pkgdesc = Python IDE for Eclipse (Stable Stream)
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = http://www.eclipse.org/dltk/
+ arch = i686
+ arch = x86_64
+ license = EPL
+ depends = eclipse-dltk-core
+ depends = eclipse-antlr-runtime>=3.0.0
+ source = http://www.eclipse.org/downloads/download.php?r=1&file=/technology/dltk/downloads/drops/R3.0/S-3.0.1-201108261011/dltk-python-S-3.0.1-201108261011.zip
+ md5sums = 0a713a146c2af010ef6c4054145d4663
+
+pkgname = eclipse-dltk-python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b2afa3f0250
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Shanto <shanto@hotmail.com>
+# Contributor: Jonathan Wiersma <archaur at jonw dot org>
+
+pkgname=eclipse-dltk-python
+pkgname=eclipse-dltk-python
+pkgver=3.0.1
+pkgrel=1
+_pkgdate=201108261011
+pkgdesc="Python IDE for Eclipse (Stable Stream)"
+arch=('i686' 'x86_64')
+url="http://www.eclipse.org/dltk/"
+license=('EPL')
+depends=("eclipse-dltk-core" "eclipse-antlr-runtime>=3.0.0")
+_mirror="http://www.eclipse.org/downloads/download.php?r=1&file="
+source=("$_mirror/technology/dltk/downloads/drops/R${pkgver:0:3}/S-$pkgver-$_pkgdate/${pkgname#eclipse-}-S-$pkgver-$_pkgdate.zip")
+md5sums=('0a713a146c2af010ef6c4054145d4663')
+
+package() {
+ cd $srcdir
+ install -dm755 $pkgdir/usr/share/eclipse/dropins/${pkgname#eclipse-}/
+ find eclipse -type f -exec install -Dm644 {} \
+ $pkgdir/usr/share/eclipse/dropins/${pkgname#eclipse-}/{} \;
+}