summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rosenstrauch2017-01-12 12:57:22 -0500
committerDavid Rosenstrauch2017-01-12 12:57:22 -0500
commitfbbbc4219af5537099633fb67365988cd31bf66d (patch)
treea23eb13aae6661508948380112aee6b4a1eb3703
downloadaur-fbbbc4219af5537099633fb67365988cd31bf66d.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d9a7c4656e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = eclipse-dltk-shelled
+ pkgdesc = Shell IDE for Eclipse
+ pkgver = 5.6
+ pkgrel = 1
+ url = http://www.eclipse.org/dltk/
+ arch = i686
+ arch = x86_64
+ license = EPL
+ depends = eclipse-dltk-core
+ optdepends = openssh
+ conflicts = eclipse-shelled
+ source = http://www.eclipse.org/downloads/download.php?r=1&file=/technology/dltk/downloads/drops/R5.6/R-5.6-201608300412/dltk-sh-R-5.6-201608300412.zip
+ md5sums = ea4cd904f6ad607d77aff96fa810b4d4
+
+pkgname = eclipse-dltk-shelled
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12336541e438
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributer: Shanto <shanto@hotmail.com>
+# Contributor: Jonathan Wiersma <archaur at jonw dot org>
+# Contributor: Arthur Zamarin <arthurzam@gmail.com>
+# Maintainer: David Rosenstrauch <darose@darose.net>
+
+pkgname=eclipse-dltk-shelled
+pkgver=5.6
+pkgrel=1
+_pkgdate="201608300412"
+pkgdesc="Shell IDE for Eclipse"
+arch=('i686' 'x86_64')
+url="http://www.eclipse.org/dltk/"
+license=('EPL')
+depends=("eclipse-dltk-core")
+optdepends=('openssh')
+conflicts=("eclipse-shelled")
+_mirror="http://www.eclipse.org/downloads/download.php?r=1&file="
+source=("$_mirror/technology/dltk/downloads/drops/R${pkgver:0:3}/R-$pkgver-$_pkgdate/dltk-sh-R-$pkgver-$_pkgdate.zip")
+md5sums=('ea4cd904f6ad607d77aff96fa810b4d4')
+
+package() {
+ cd $srcdir
+ install -dm755 $pkgdir/usr/lib/eclipse/dropins/${pkgname#eclipse-}/
+ find . -type f -exec install -Dm644 {} \
+ $pkgdir/usr/lib/eclipse/dropins/${pkgname#eclipse-}/{} \;
+}