summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWyatt J. Brown2015-06-15 22:38:18 -0400
committerWyatt J. Brown2015-06-15 22:38:18 -0400
commit890b334a9891171b951f1bf460497d65c1888239 (patch)
tree88ea1aaf06105a41ca25934be54d5aa857b2ccfb
downloadaur-890b334a9891171b951f1bf460497d65c1888239.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7bb4134b769
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 4.2.1
+# Mon May 4 05:32:53 UTC 2015
+pkgbase = eclipse-egit
+ pkgdesc = An Eclipse Team provider for the Git version control system.
+ pkgver = 3.7.1.201504261725_r
+ pkgrel = 1
+ url = https://www.eclipse.org/egit/
+ arch = any
+ license = EPL
+ depends = eclipse
+ depends = eclipse-mylyn
+ source = https://www.eclipse.org/downloads/download.php?file=/egit/updates/org.eclipse.egit.repository-3.7.1.201504261725-r.zip&r=1
+ sha512sums = fafd12ad76c23596f93f32177b017f2c752137660e9d4f1048bc09e9de5b6ff6b8b5cf51ef6d21994c5997f2ecc5bb4c7dc0b9427c33cca56809735effda242f
+
+pkgname = eclipse-egit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d57d7335da02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Wyatt J. Brown <sushidudeteam@gmail.com>
+# Contributor: Alex Ferrando <alferpal@gmail.com>
+# Contributor: Archan Paul <arp@archan.org>
+pkgname=eclipse-egit
+pkgver=3.7.1.201504261725_r
+pkgrel=1
+pkgdesc='An Eclipse Team provider for the Git version control system.'
+arch=('any')
+url='https://www.eclipse.org/egit/'
+license=('EPL')
+depends=('eclipse' 'eclipse-mylyn')
+source=("https://www.eclipse.org/downloads/download.php?file=/egit/updates/org.eclipse.egit.repository-$(echo $pkgver | sed s/_/-/).zip&r=1")
+sha512sums=('fafd12ad76c23596f93f32177b017f2c752137660e9d4f1048bc09e9de5b6ff6b8b5cf51ef6d21994c5997f2ecc5bb4c7dc0b9427c33cca56809735effda242f')
+
+prepare()
+{
+ # remove features and plug-ins containing sources
+ rm features/*.source_*
+ rm plugins/*.source_*
+ # remove gz files
+ rm plugins/*.pack.gz
+}
+
+package()
+{
+ _dest=${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+
+ # Features
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ # extract features (otherwise they are not visible in about dialog)
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+
+ # Plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 "${_plugin}" "${_dest}/${_plugin}"
+ done
+}