summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2019-10-06 09:48:49 +0200
committerRaimar Bühmann2019-10-06 09:50:11 +0200
commitc8f6036d41ba74744744bdfe319a9b897475c9ab (patch)
tree6ed9dd06ffadeb41335dcdd8a2c0fc51ee296a92
downloadaur-c8f6036d41ba74744744bdfe319a9b897475c9ab.tar.gz
update to 2.11.0-2
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..243e4cb1bf03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = eclipse-emft-mwe
+ pkgdesc = Model Workflow Engine plug-in for Eclipse IDE
+ pkgver = 2.11.0
+ pkgrel = 2
+ url = https://www.eclipse.org/modeling/emft/
+ arch = any
+ license = EPL
+ depends = eclipse-emf
+ options = !strip
+ source = http://download.eclipse.org/modeling/emft/mwe/downloads/drops/2.11.0/R201906111547/emft-mwe-2-lang-Update-2.11.0.zip
+ sha256sums = 6c423d693ab8c4fd152238d001e2192dbda6142096377ed49009403c371149e0
+
+pkgname = eclipse-emft-mwe
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..da7728b8a8c0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+emft-mwe-*.zip
+eclipse-*-any.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..649e49db5ac9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Raimar Buehmann <raimar _at_ buehmann _dot_ de>
+
+pkgname=eclipse-emft-mwe
+pkgver=2.11.0
+_buildtime=R201906111547
+pkgrel=2
+pkgdesc="Model Workflow Engine plug-in for Eclipse IDE"
+arch=('any')
+url="https://www.eclipse.org/modeling/emft/"
+license=('EPL')
+depends=('eclipse-emf')
+options=('!strip')
+# http://www.eclipse.org/modeling/download.php?file=/modeling/emft/mwe/downloads/drops/2.11.0/R201906111547/emft-mwe-2-lang-Update-2.11.0.zip
+source=(
+ http://download.eclipse.org/modeling/emft/mwe/downloads/drops/${pkgver}/${_buildtime}/emft-mwe-2-lang-Update-${pkgver}.zip
+)
+sha256sums=('6c423d693ab8c4fd152238d001e2192dbda6142096377ed49009403c371149e0')
+
+package() {
+ _dest=${pkgdir}/usr/lib/eclipse/dropins/${pkgname/eclipse-}/eclipse
+ cd ${srcdir}
+
+ # Features
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+
+ # Plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
+}