summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commit031f18b6d1a42cfd30cc2418b966223171402775 (patch)
treecf6e35098f2ddb749ff18c413803e3f822a19f5f
downloadaur-031f18b6d1a42cfd30cc2418b966223171402775.tar.gz
Initial Commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD52
-rw-r--r--eclipse-galileo.install12
-rw-r--r--eclipse.desktop9
-rw-r--r--eclipse.ini.patch12
-rw-r--r--eclipse.sh4
6 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0435c054a027
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = eclipse-galileo
+ pkgdesc = An IDE for Java and other languages - Galileo
+ pkgver = 3.5.2
+ pkgrel = 2
+ url = http://www.eclipse.org/
+ install = eclipse-galileo.install
+ arch = i686
+ arch = x86_64
+ license = EPL
+ depends = desktop-file-utils
+ depends = java-environment
+ depends = python2
+ depends = xulrunner
+ provides = eclipse
+ conflicts = eclipse
+ source = http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops/R-3.5.2-201002111343/eclipse-SDK-3.5.2-linux-gtk.tar.gz
+ source = eclipse.desktop
+ source = eclipse.ini.patch
+ source = eclipse.sh
+ md5sums = bde55a2354dc224cf5f26e5320e72dac
+ md5sums = feb32dc323efc161cf044a36eeb5ec4d
+ md5sums = 74165d9a60ecc841d021567270b14fd5
+ md5sums = 7ea99a30fbaf06ec29261541b8eb1e23
+
+pkgname = eclipse-galileo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05b1b8cc1b92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Ricardo Funke Ormieres <ricardo.funke at gmail dot com>
+# Contributor: Alessio Sergi <asergi at archlinux dot us>
+
+pkgname=eclipse-galileo
+_realname=eclipse
+pkgver=3.5.2
+_internal_pkgver=3.5.2
+pkgrel=2
+_date=201002111343
+pkgdesc="An IDE for Java and other languages - Galileo"
+arch=('i686' 'x86_64')
+url="http://www.eclipse.org/"
+license=('EPL')
+depends=('desktop-file-utils' 'java-environment' 'python2' 'xulrunner')
+provides=(${_realname})
+conflicts=(${_realname})
+install=${pkgname}.install
+source=("http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops/R-${pkgver}-${_date}/${_realname}-SDK-${pkgver}-linux-gtk.tar.gz"
+ "eclipse.desktop"
+ "eclipse.ini.patch"
+ "eclipse.sh")
+md5sums=('bde55a2354dc224cf5f26e5320e72dac'
+ 'feb32dc323efc161cf044a36eeb5ec4d'
+ '74165d9a60ecc841d021567270b14fd5'
+ '7ea99a30fbaf06ec29261541b8eb1e23')
+[ "${CARCH}" = "x86_64" ] && source[0]="http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops/R-${pkgver}-${_date}/${_realname}-SDK-${pkgver}-linux-gtk-${CARCH}.tar.gz"
+[ "${CARCH}" = "x86_64" ] && md5sums[0]='54e2ce0660b2b1b0eb4267acf70ea66d'
+
+package() {
+ cd "${srcdir}/eclipse"
+
+ # patch to increase default memory limits
+ patch -Np0 -i ${srcdir}/eclipse.ini.patch
+
+ # python2 fix
+ sed -i 's|#!/usr/bin/python|#!/usr/bin/python2|' \
+ plugins/org.apache.ant_1.7.1.v20090120-1145/bin/runant.py
+
+ # install eclipse
+ install -d -m755 ${pkgdir}/usr/share/${_realname}
+ cp -r * ${pkgdir}/usr/share/${_realname}/
+
+ # install bin file
+ install -d -m755 ${pkgdir}/usr/bin
+ install -m755 ${srcdir}/${_realname}.sh ${pkgdir}/usr/bin/${_realname}
+
+ # install icon and desktop files
+ install -d -m755 ${pkgdir}/usr/share/{applications,pixmaps}
+ install -m644 ${srcdir}/${_realname}.desktop ${pkgdir}/usr/share/applications/
+ install -m644 plugins/org.eclipse.sdk_${_internal_pkgver}.v${_date}/${_realname}48.png \
+ ${pkgdir}/usr/share/pixmaps/${_realname}.png
+}
diff --git a/eclipse-galileo.install b/eclipse-galileo.install
new file mode 100644
index 000000000000..e3475f070faf
--- /dev/null
+++ b/eclipse-galileo.install
@@ -0,0 +1,12 @@
+post_install() {
+ xulrunner --register-global >/dev/null 2>&1
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ update-desktop-database -q
+}
diff --git a/eclipse.desktop b/eclipse.desktop
new file mode 100644
index 000000000000..8fb93ad9a09a
--- /dev/null
+++ b/eclipse.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Eclipse - Galileo
+Comment=A Java Development Environment
+Icon=eclipse
+Exec=eclipse
+Terminal=false
+Type=Application
+Categories=Development;IDE;Java
+StartupNotify=true
diff --git a/eclipse.ini.patch b/eclipse.ini.patch
new file mode 100644
index 000000000000..3d80aefa6c95
--- /dev/null
+++ b/eclipse.ini.patch
@@ -0,0 +1,12 @@
+--- eclipse.ini.orig 2010-02-12 18:47:34.000000000 +0100
++++ eclipse.ini 2011-02-16 12:50:06.846666767 +0100
+@@ -5,7 +5,7 @@
+ -showsplash
+ org.eclipse.platform
+ --launcher.XXMaxPermSize
+-256m
++512m
+ -vmargs
+ -Xms40m
+--Xmx256m
++-Xmx768m
diff --git a/eclipse.sh b/eclipse.sh
new file mode 100644
index 000000000000..498d7fefbde1
--- /dev/null
+++ b/eclipse.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+export ECLIPSE_HOME=/usr/share/eclipse
+export GDK_NATIVE_WINDOWS=true
+${ECLIPSE_HOME}/eclipse "$@"