summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commit9e1dba3508fc847b56b96157a6becff225366291 (patch)
treef361ef0b090b83ae0865043865da7137687ea2f7
downloadaur-9e1dba3508fc847b56b96157a6becff225366291.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8bc5077267a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = eclipse-gef
+ pkgdesc = GEF framework for the Eclipse platform
+ pkgver = 3.9.101
+ pkgrel = 1
+ url = http://www.eclipse.org/gef/
+ arch = any
+ license = EPL
+ depends = eclipse
+ source = http://www.eclipse.org/downloads/download.php?r=1&file=/tools/gef/downloads/drops/3.9.101/R201408150207/GEF-ALL-3.9.101.zip
+ sha256sums = 07a8f38e67bf01c9fe74b930b23a22b2830049000a4ea2d631036d1901830ce5
+ sha512sums = dbb74764947fd49cdb0336ca66031c88c89fc90697336dcb70cc2ccc33e97aa9d169a813c8b7d2d79fcc1a0effe473945c4fc363927d6ebbdc043ad02c31e780
+
+pkgname = eclipse-gef
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43dbcd6d57ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Arthur Zamarin <arthurzam@gmail.com>
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Stéphane Marguet (Stemp) <smarguet@gmail.com>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Corrado Primier <bardo@aur.archlinux.org>
+# Contributor: Rubin Simons <rubin@xs4all.nl>
+
+pkgname=eclipse-gef
+pkgver=3.9.101
+_reldate=201408150207
+pkgrel=1
+pkgdesc="GEF framework for the Eclipse platform"
+arch=(any)
+url=http://www.eclipse.org/gef/
+license=(EPL)
+depends=(eclipse)
+_mirror="http://www.eclipse.org/downloads/download.php?r=1&file="
+source=($_mirror/tools/gef/downloads/drops/$pkgver/R$_reldate/GEF-ALL-$pkgver.zip)
+sha256sums=('07a8f38e67bf01c9fe74b930b23a22b2830049000a4ea2d631036d1901830ce5')
+sha512sums=('dbb74764947fd49cdb0336ca66031c88c89fc90697336dcb70cc2ccc33e97aa9d169a813c8b7d2d79fcc1a0effe473945c4fc363927d6ebbdc043ad02c31e780')
+
+package() {
+ _dest="$pkgdir"/usr/share/eclipse/dropins/${pkgname#*-}/eclipse
+
+ cd eclipse/
+ # Features
+ find features -type f | while read _feature ; do
+ if [[ $_feature =~ (.*\.jar$) ]] ; then
+ install -d "${_dest}"/${_feature%*.jar}
+ cd "$_dest"/${_feature/.jar}
+ jar xf "${srcdir}/${_feature}"
+ else
+ install -Dm644 $_feature "$_dest/$_feature"
+ fi
+ done
+
+ # Plugins
+ find plugins -type f -exec install -Dm644 '{}' "$_dest"/'{}' \;
+}