summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commitace3c905d03d26bb89b172b47c25dfa417176381 (patch)
tree0b03332bdecb45dd7e1a5cac30dc53a6aab7d122
downloadaur-ace3c905d03d26bb89b172b47c25dfa417176381.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab155c1f549d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = eclipse-jadclipse
+ pkgdesc = JadClipse is a plug-in that seamlessly integrates Jad (the fast Java decompiler) with Eclipse.
+ pkgver = 3.3.0
+ pkgrel = 3
+ url = http://jadclipse.sourceforge.net/
+ arch = any
+ license = CPL
+ depends = eclipse
+ depends = jad
+ source = http://prdownloads.sourceforge.net/jadclipse/net.sf.jadclipse_3.3.0.jar
+ md5sums = 7228a814ad218aa16808ece80407d364
+
+pkgname = eclipse-jadclipse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f50948f0af68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=eclipse-jadclipse
+pkgver=3.3.0
+pkgrel=3
+pkgdesc='JadClipse is a plug-in that seamlessly integrates Jad (the fast Java decompiler) with Eclipse.'
+arch=('any')
+url='http://jadclipse.sourceforge.net/'
+license=('CPL')
+depends=('eclipse' 'jad')
+optdepends=()
+source=(http://prdownloads.sourceforge.net/jadclipse/net.sf.jadclipse_${pkgver}.jar)
+md5sums=('7228a814ad218aa16808ece80407d364')
+
+package() {
+ _dest=${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+ mkdir -p "$_dest/plugins"
+ install -Dm644 "$srcdir/net.sf.jadclipse_$pkgver.jar" "$_dest/plugins/"
+}