summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFiras Zaidan2015-06-10 00:25:02 +0200
committerFiras Zaidan2015-06-10 00:25:02 +0200
commitc27491bf5df621222639a193a3371e07129d7040 (patch)
tree46f4f16f597db257e5f07fa51deb12b27aa0fb35
downloadaur-c27491bf5df621222639a193a3371e07129d7040.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7020dca25a01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = eclipse-jautodoc
+ pkgdesc = JAutodoc is an Eclipse Plugin for automatically adding Javadoc and file headers to your source code.
+ pkgver = 1.12.0
+ pkgrel = 1
+ url = http://jautodoc.sourceforge.net/
+ arch = any
+ license = Eclipse Public License 1.0,
+ license = Apache License 2.0
+ depends = eclipse
+ source = http://sourceforge.net/projects/jautodoc/files/jautodoc/1.12.0/jautodoc_1.12.0.zip
+ sha512sums = d963bdacde4f37b9237ae13c66600d1701502947ba7fd9d8f942c32073ea82da1cdb77149dae30ef3adf9e2c3d00beeafb4c0629b7a891299c2ccd0c3563cbbe
+
+pkgname = eclipse-jautodoc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a5dfd68b8df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: fqqbar
+
+pkgname=eclipse-jautodoc
+pkgver=1.12.0
+pkgrel=1
+pkgdesc="JAutodoc is an Eclipse Plugin for automatically adding Javadoc and file headers to your source code."
+url="http://jautodoc.sourceforge.net/"
+arch=('any')
+license=('Eclipse Public License 1.0', 'Apache License 2.0')
+depends=('eclipse')
+source=("http://sourceforge.net/projects/jautodoc/files/jautodoc/${pkgver}/jautodoc_${pkgver}.zip")
+sha512sums=('d963bdacde4f37b9237ae13c66600d1701502947ba7fd9d8f942c32073ea82da1cdb77149dae30ef3adf9e2c3d00beeafb4c0629b7a891299c2ccd0c3563cbbe')
+
+# no build() needed
+package() {
+ _dest=${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+
+ cd ${srcdir}
+
+ # Features
+ find features -type f | while read _feature ; do
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ done
+
+ # Plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
+}