summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2015-06-08 20:32:23 +0200
committerRaimar Bühmann2015-06-08 20:32:23 +0200
commit7f34c17d01a6a4650a2b1034620b1ef5ddf00946 (patch)
tree85e481f71709614f40a9c11635fda6be0b1d1dea
downloadaur-7f34c17d01a6a4650a2b1034620b1ef5ddf00946.tar.gz
initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..722f6433f3a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = eclipse-jboss
+ pkgdesc = Developer tools for JBoss application server
+ pkgver = 4.2.3.Final
+ pkgrel = 1
+ url = http://tools.jboss.org/
+ arch = any
+ license = LGPL
+ license = EPL
+ license = BSD
+ depends = eclipse>=4.3.0
+ options = !strip
+ source = jbosstools-4.2.3.Final-updatesite-core.zip::http://downloads.sourceforge.net/project/jboss/JBossTools/jbosstools4.2.x/jbosstools-4.2.3.Final_2015-03-26_22-41-56-B370-updatesite-core.zip?r=&ts=1428435258&use_mirror=cologne
+ md5sums = ad24d50352b009930ffcfb3e13a21a07
+
+pkgname = eclipse-jboss
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe29cfc542c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+#Maintainer: Raimar Buehmann <raimar _at_ buehmann _dot_ de>
+
+pkgname=eclipse-jboss
+_mainver=4.2
+pkgver=${_mainver}.3.Final
+pkgrel=1
+pkgdesc='Developer tools for JBoss application server'
+arch=('any')
+url='http://tools.jboss.org/'
+license=('LGPL' 'EPL' 'BSD')
+depends=('eclipse>=4.3.0')
+options=('!strip')
+source=("jbosstools-${pkgver}-updatesite-core.zip::http://downloads.sourceforge.net/project/jboss/JBossTools/jbosstools${_mainver}.x/jbosstools-${pkgver}_2015-03-26_22-41-56-B370-updatesite-core.zip?r=&ts=1428435258&use_mirror=cologne")
+md5sums=('ad24d50352b009930ffcfb3e13a21a07')
+
+package() {
+ # remove features and plug-ins containing sources
+ rm features/*.source_*
+ rm plugins/*.source_*
+ # remove gz files
+ rm plugins/*.pack.gz
+ _dest=${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+ install -d $_dest
+ # extract features (otherwise features are not recognized)
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+ # copy plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
+}