summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:17 +0200
committerMuflone2015-06-13 17:59:17 +0200
commitbb345e034549fd69e1e1c1e064b5a3307162f470 (patch)
tree3864dcc849f880084de9f766afedf892426dc0d7
downloadaur-bb345e034549fd69e1e1c1e064b5a3307162f470.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD62
-rw-r--r--eclipse-jee.install11
-rw-r--r--eclipse.desktop9
-rw-r--r--eclipse.ini.patch19
-rw-r--r--eclipse.sh4
-rw-r--r--eclipse.svg119
7 files changed, 251 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c7bb9e64d32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = eclipse-jee
+ pkgdesc = Eclipse IDE for Java EE Developers
+ pkgver = 4.4.2
+ pkgrel = 1
+ url = http://www.eclipse.org
+ install = eclipse-jee.install
+ arch = i686
+ arch = x86_64
+ license = EPL
+ depends = java-environment>=6
+ depends = gtk2
+ depends = webkitgtk2
+ provides = eclipse=4.4.2
+ conflicts = eclipse
+ source = eclipse-jee-luna-SR2-linux-gtk.tar.gz::http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/luna/SR2/eclipse-jee-luna-SR2-linux-gtk.tar.gz&r=1
+ source = eclipse.sh
+ source = eclipse.desktop
+ source = eclipse.ini.patch
+ source = eclipse.svg
+ sha256sums = 3c6af9a3586ea7b8ca5e3b2c5c1842bfa4dcc6e68ebb2052edad0a07902e2d29
+ sha256sums = 9fdf02d827e5f3b44146a0532c463ef44d0bf3aa57d0be4f2acccc38a170915b
+ sha256sums = 4eb2189c96fcfa340886b049b34dc3636d7b2bfa865140dc72edb61455d900c3
+ sha256sums = 4a86578ebbe8adddf731b6bef31c05277ea792cb22d733b6a5c0a25f65546caf
+ sha256sums = da103fe3b9d8c6cc1316b2b45347697bf6561230e81286b78cf142b64b1d89a5
+
+pkgname = eclipse-jee
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e262b21767fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: Giuliano Schneider <gs93@gmx.net>
+# Contributor: [Vitaliy Berdinskikh](mailto:ur6lad@archlinux.org.ua) aka UR6LAD
+
+_eclipse_name=luna
+_eclipse_release=SR2
+pkgname=eclipse-jee
+pkgver=4.4.2
+pkgrel=1
+pkgdesc="Eclipse IDE for Java EE Developers"
+arch=('i686' 'x86_64')
+url="http://www.eclipse.org"
+license=('EPL')
+depends=('java-environment>=6' 'gtk2' 'webkitgtk2')
+provides=("eclipse=${pkgver}")
+conflicts=('eclipse')
+install="${pkgname}.install"
+sha256sums=('3c6af9a3586ea7b8ca5e3b2c5c1842bfa4dcc6e68ebb2052edad0a07902e2d29'
+ '9fdf02d827e5f3b44146a0532c463ef44d0bf3aa57d0be4f2acccc38a170915b'
+ '4eb2189c96fcfa340886b049b34dc3636d7b2bfa865140dc72edb61455d900c3'
+ '4a86578ebbe8adddf731b6bef31c05277ea792cb22d733b6a5c0a25f65546caf'
+ 'da103fe3b9d8c6cc1316b2b45347697bf6561230e81286b78cf142b64b1d89a5')
+if [ "$CARCH" = 'x86_64' ]; then
+ sha256sums[0]='d66cc43c6f064a277f7c61d58fa982e4f95c2addba3d2b4c14c829d2291cb78e'
+ _arch="-${CARCH}"
+fi
+source=("${pkgname}-${_eclipse_name}-${_eclipse_release}-linux-gtk${_arch}.tar.gz"::"http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/${_eclipse_name}/${_eclipse_release}/${pkgname}-${_eclipse_name}-${_eclipse_release}-linux-gtk${_arch}.tar.gz&r=1"
+ "eclipse.sh"
+ "eclipse.desktop"
+ "eclipse.ini.patch"
+ "eclipse.svg")
+# prevent package compression
+PKGEXT=".pkg.tar"
+
+build() {
+ patch -p1 -i "eclipse.ini.patch"
+}
+
+package() {
+ # Copy application files
+ install -m 755 -d "${pkgdir}/usr/share"
+ cp -a "eclipse" "${pkgdir}/usr/share"
+
+ # Copy executable file
+ install -m 755 -d "${pkgdir}/usr/bin"
+ install -m 755 eclipse.sh "${pkgdir}/usr/bin/eclipse"
+
+ # Copy icons
+ install -m 755 -d "${pkgdir}/usr/share/icons"
+ for _size in 16 32 48 256
+ do
+ install -m 755 -d "${pkgdir}/usr/share/icons/hicolor/${_size}x${_size}/apps"
+ install -m 644 eclipse/plugins/org.eclipse.platform_4.*.v*/eclipse${_size}.png \
+ "${pkgdir}/usr/share/icons/hicolor/${_size}x${_size}/apps/eclipse.png"
+ done
+ install -m 755 -d "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
+ install -m 644 "eclipse.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/eclipse.svg"
+
+ # Copy desktop file
+ install -m 755 -d "${pkgdir}/usr/share/applications"
+ install -m 755 "eclipse.desktop" "${pkgdir}/usr/share/applications/eclipse.desktop"
+}
diff --git a/eclipse-jee.install b/eclipse-jee.install
new file mode 100644
index 000000000000..d59dca6e808e
--- /dev/null
+++ b/eclipse-jee.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/eclipse.desktop b/eclipse.desktop
new file mode 100644
index 000000000000..1b57fec6bc63
--- /dev/null
+++ b/eclipse.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Eclipse
+Comment=A Java Development Environment
+Exec=eclipse
+Icon=eclipse
+Terminal=false
+Type=Application
+Categories=Java;Development;IDE;
+StartupNotify=true
diff --git a/eclipse.ini.patch b/eclipse.ini.patch
new file mode 100644
index 000000000000..bff595e83760
--- /dev/null
+++ b/eclipse.ini.patch
@@ -0,0 +1,19 @@
+diff -ur a/eclipse/eclipse.ini b/eclipse/eclipse.ini
+--- a/eclipse/eclipse.ini 2012-06-14 20:50:32.000000000 +0300
++++ b/eclipse/eclipse.ini 2012-09-20 23:02:43.000000000 +0300
+@@ -9,7 +9,7 @@
+ -showsplash
+ org.eclipse.platform
+ --launcher.XXMaxPermSize
+-256m
++512m
+ --launcher.defaultAction
+ openFile
+ -vmargs
+@@ -17,4 +17,5 @@
+ -Dhelp.lucene.tokenizer=standard
+ -XX:MaxPermSize=256m
+ -Xms40m
+--Xmx512m
++-Xmx768m
++-Dosgi.configuration.area=@user.home/.config/eclipse
diff --git a/eclipse.sh b/eclipse.sh
new file mode 100644
index 000000000000..498d7fefbde1
--- /dev/null
+++ b/eclipse.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+export ECLIPSE_HOME=/usr/share/eclipse
+export GDK_NATIVE_WINDOWS=true
+${ECLIPSE_HOME}/eclipse "$@"
diff --git a/eclipse.svg b/eclipse.svg
new file mode 100644
index 000000000000..9a3e8c49f9af
--- /dev/null
+++ b/eclipse.svg
@@ -0,0 +1,119 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:xlink="http://www.w3.org/1999/xlink"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="256"
+ height="256"
+ id="svg2"
+ version="1.1"
+ inkscape:version="0.48.5 r10040"
+ sodipodi:docname="Nuovo documento 1">
+ <defs
+ id="defs4">
+ <linearGradient
+ id="linearGradient3892">
+ <stop
+ style="stop-color:#463788;stop-opacity:1;"
+ offset="0"
+ id="stop3894" />
+ <stop
+ style="stop-color:#463788;stop-opacity:0;"
+ offset="1"
+ id="stop3896" />
+ </linearGradient>
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient3892"
+ id="linearGradient3898"
+ x1="142.24303"
+ y1="228.04634"
+ x2="143.72633"
+ y2="19.627708"
+ gradientUnits="userSpaceOnUse" />
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient3892"
+ id="linearGradient4039"
+ gradientUnits="userSpaceOnUse"
+ x1="142.24303"
+ y1="228.04634"
+ x2="143.72633"
+ y2="19.627708" />
+ </defs>
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="1.4756825"
+ inkscape:cx="28.356784"
+ inkscape:cy="116.33584"
+ inkscape:document-units="px"
+ inkscape:current-layer="layer3"
+ showgrid="false"
+ inkscape:window-width="1366"
+ inkscape:window-height="702"
+ inkscape:window-x="0"
+ inkscape:window-y="27"
+ inkscape:window-maximized="1" />
+ <metadata
+ id="metadata7">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title></dc:title>
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:groupmode="layer"
+ id="layer3"
+ inkscape:label="Livello">
+ <path
+ style="fill:#f7941e;fill-opacity:1;stroke:none;opacity:1"
+ d="M 115.875 11.375 C 51.877022 11.375 0 63.252022 0 127.25 C 0 191.24798 51.877022 243.125 115.875 243.125 C 119.24725 243.125 122.57585 242.96978 125.875 242.6875 C 66.563577 237.61269 20 187.87572 20 127.25 C 20 66.624275 66.563577 16.887315 125.875 11.8125 C 122.57585 11.530218 119.24725 11.375 115.875 11.375 z "
+ id="path3070" />
+ <g
+ id="g4032"
+ transform="translate(100,0)">
+ <path
+ transform="matrix(1.0167013,0,0,0.99870512,-104.3727,0.2419774)"
+ d="m 254.1197,127.92367 c 0,61.37817 -49.75684,111.13502 -111.13502,111.13502 -61.378175,0 -111.135017,-49.75685 -111.135017,-111.13502 0,-61.378177 49.756842,-111.135019 111.135017,-111.135019 61.37818,0 111.13502,49.756842 111.13502,111.135019 z"
+ sodipodi:ry="111.13502"
+ sodipodi:rx="111.13502"
+ sodipodi:cy="127.92367"
+ sodipodi:cx="142.98468"
+ id="path3872"
+ style="fill:#2c2255;fill-opacity:1;stroke:#000000;stroke-width:3.96958089;stroke-miterlimit:4;stroke-dasharray:none"
+ sodipodi:type="arc" />
+ <path
+ transform="matrix(0.67523787,0,0,0.66328578,-55.54866,43.150051)"
+ d="m 254.1197,127.92367 c 0,61.37817 -49.75684,111.13502 -111.13502,111.13502 -61.378175,0 -111.135017,-49.75685 -111.135017,-111.13502 0,-61.378177 49.756842,-111.135019 111.135017,-111.135019 61.37818,0 111.13502,49.756842 111.13502,111.135019 z"
+ sodipodi:ry="111.13502"
+ sodipodi:rx="111.13502"
+ sodipodi:cy="127.92367"
+ sodipodi:cx="142.98468"
+ id="path3872-1"
+ style="fill:url(#linearGradient4039);fill-opacity:1;stroke:none"
+ sodipodi:type="arc" />
+ <path
+ inkscape:connector-curvature="0"
+ id="rect3900"
+ d="m -65.79729,95.625 c -1.2006,3.918982 -2.201169,7.91034 -2.964018,12 l 219.522618,0 c -0.76285,-4.08966 -1.76342,-8.081018 -2.96402,-12 l -213.59458,0 z m -4.662154,26 c -0.120066,2.10891 -0.185251,4.23621 -0.185251,6.375 0,1.88407 0.06106,3.76397 0.154376,5.625 l 222.980639,0 c 0.0933,-1.86103 0.15437,-3.74093 0.15437,-5.625 0,-2.13879 -0.0652,-4.26609 -0.18525,-6.375 l -222.918884,0 z m 1.574635,26 c 0.733123,4.0871 1.670574,8.08093 2.840518,12 l 214.088581,0 c 1.16995,-3.91907 2.1074,-7.9129 2.84052,-12 l -219.769619,0 z"
+ style="fill:#ffffff;fill-opacity:1;stroke:none" />
+ </g>
+ </g>
+</svg>