summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-07-25 17:29:27 +0300
committerArthur Zamarin2015-07-25 17:29:27 +0300
commit3c4f5d317d2d809d61d0e28064e796840abd0aa8 (patch)
tree1c24421697396c040267afe016f10134441a9828
parent9479e47041da96227e7756e2bc676f4d484f5456 (diff)
downloadaur-3c4f5d317d2d809d61d0e28064e796840abd0aa8.tar.gz
Update for Eclipse Mars
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb10e55ffa98..b45a24927473 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = eclipse-linuxtools
pkgdesc = Eclipse Linux Tools Project
- pkgver = 3.2.0
- pkgrel = 2
+ pkgver = 4.0.0
+ pkgrel = 1
url = http://www.eclipse.org/linuxtools
arch = any
license = EPL
makedepends = java-environment
- depends = eclipse-cdt
+ depends = eclipse-cpp
optdepends = eclipse-ptp: remote profiling
optdepends = eclipse-rse: LTTng and remote profiling
optdepends = eclipse-gef: Draw2d and Zest
optdepends = eclipse-tcf: legacy LTTng
optdepends = eclipse-antlr-runtime: Tracing/LTTng
- source = http://www.eclipse.org/downloads/download.php?r=1&file=/linuxtools/linuxtools-3.2.0.zip
- sha256sums = 332c1bba17e987066d831a76f035ccf68c5056a694c183c70fc62f8d5814407d
+ source = http://www.eclipse.org/downloads/download.php?r=1&file=/linuxtools/linuxtools-4.0.0.zip
+ sha256sums = 541d4f75911b9f52a81b26ded143deea52d46fc08a994a686b6edb9972a2af72
pkgname = eclipse-linuxtools
diff --git a/PKGBUILD b/PKGBUILD
index 133cd6ce4dca..45650a9524e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Maintainer: Arthur Zamarin <arthurzam@gmail.com>
pkgname=eclipse-linuxtools
-pkgver=3.2.0
-pkgrel=2
+pkgver=4.0.0
+pkgrel=1
pkgdesc="Eclipse Linux Tools Project"
url="http://www.eclipse.org/linuxtools"
arch=('any')
license=('EPL')
-depends=('eclipse-cdt')
+depends=('eclipse-cpp')
optdepends=(
'eclipse-ptp: remote profiling'
'eclipse-rse: LTTng and remote profiling'
@@ -19,11 +19,22 @@ optdepends=(
)
makedepends=('java-environment')
source=("http://www.eclipse.org/downloads/download.php?r=1&file=/linuxtools/linuxtools-${pkgver}.zip")
-sha256sums=('332c1bba17e987066d831a76f035ccf68c5056a694c183c70fc62f8d5814407d')
+sha256sums=('541d4f75911b9f52a81b26ded143deea52d46fc08a994a686b6edb9972a2af72')
package() {
- d="$pkgdir/usr/share/eclipse/dropins/linuxtools/eclipse"
- install -d "$d"
- cp -a features "$d"
- cp -a plugins "$d"
+ _dest="${pkgdir}/usr/lib/eclipse/dropins/linuxtools/eclipse"
+
+ cd "${srcdir}"
+
+ # Features
+ for _f in features/*; do
+ _dir="${_dest}/${_f/.jar}"
+ mkdir -p "${_dir}"
+ bsdtar -xf "${_f}" -C "${_dir}"
+ done
+
+ # Plugins
+ for _p in plugins/*; do
+ install -Dm644 "${_p}" "${_dest}/${_p}"
+ done
}