summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-10-12 17:30:28 +0300
committerArthur Zamarin2015-10-12 17:30:28 +0300
commitfa368955c44476d4f9b4995ee25d6fdf5cfc9112 (patch)
treef4c78a0ef9496297709d45df0bdc05dcd8932ee6
parent3c4f5d317d2d809d61d0e28064e796840abd0aa8 (diff)
downloadaur-fa368955c44476d4f9b4995ee25d6fdf5cfc9112.tar.gz
Update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 9 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b45a24927473..7f538486d48f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eclipse-linuxtools
pkgdesc = Eclipse Linux Tools Project
- pkgver = 4.0.0
+ pkgver = 4.1.0
pkgrel = 1
url = http://www.eclipse.org/linuxtools
arch = any
@@ -12,8 +12,8 @@ pkgbase = eclipse-linuxtools
optdepends = eclipse-gef: Draw2d and Zest
optdepends = eclipse-tcf: legacy LTTng
optdepends = eclipse-antlr-runtime: Tracing/LTTng
- source = http://www.eclipse.org/downloads/download.php?r=1&file=/linuxtools/linuxtools-4.0.0.zip
- sha256sums = 541d4f75911b9f52a81b26ded143deea52d46fc08a994a686b6edb9972a2af72
+ source = http://www.eclipse.org/downloads/download.php?r=1&file=/linuxtools/linuxtools-4.1.0.zip
+ sha256sums = ea5e28a92085d83df3b60d8b3cb43bbcce97f34c3d9a81536eaac449a25bb8a8
pkgname = eclipse-linuxtools
diff --git a/PKGBUILD b/PKGBUILD
index 45650a9524e4..7fb2c075bd54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Arthur Zamarin <arthurzam@gmail.com>
pkgname=eclipse-linuxtools
-pkgver=4.0.0
+pkgver=4.1.0
pkgrel=1
pkgdesc="Eclipse Linux Tools Project"
url="http://www.eclipse.org/linuxtools"
@@ -19,22 +19,11 @@ optdepends=(
)
makedepends=('java-environment')
source=("http://www.eclipse.org/downloads/download.php?r=1&file=/linuxtools/linuxtools-${pkgver}.zip")
-sha256sums=('541d4f75911b9f52a81b26ded143deea52d46fc08a994a686b6edb9972a2af72')
+sha256sums=('ea5e28a92085d83df3b60d8b3cb43bbcce97f34c3d9a81536eaac449a25bb8a8')
package() {
- _dest="${pkgdir}/usr/lib/eclipse/dropins/linuxtools/eclipse"
-
- cd "${srcdir}"
-
- # Features
- for _f in features/*; do
- _dir="${_dest}/${_f/.jar}"
- mkdir -p "${_dir}"
- bsdtar -xf "${_f}" -C "${_dir}"
- done
-
- # Plugins
- for _p in plugins/*; do
- install -Dm644 "${_p}" "${_dest}/${_p}"
- done
+ d="$pkgdir/usr/lib/eclipse/dropins/linuxtools/eclipse"
+ install -d "$d"
+ cp -a features "$d"
+ cp -a plugins "$d"
}