summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 13:56:53 -0600
committerJohn D Jones III2015-06-16 13:56:53 -0600
commit5713f737ca0a43d4c0e16e76fa7ba724b7aaef2b (patch)
tree321f9dbc8ba6655c8ee900f364fe08265c2f0773
downloadaur-5713f737ca0a43d4c0e16e76fa7ba724b7aaef2b.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE36
-rw-r--r--PKGBUILD42
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e2d90188d5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = eclipse-luaeclipse
+ pkgdesc = Eclipse plugin for the development of applications in the Lua programming language.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = http://luaeclipse.luaforge.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = eclipse
+ source = http://luaforge.net/frs/download.php/3193/luaeclipse-1.2.0.zip
+ source = LICENSE
+ md5sums = f735a47b31186aac90aca30e485d00f5
+ md5sums = 84e13cfae8aac2d34107f67fbec06ca7
+
+pkgname = eclipse-luaeclipse
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..abf1025ba8f6
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,36 @@
+
+LuaEclipse is free software: it can be used for both academic and commercial
+purposes at absolutely no cost. There are no royalties or GNU-like "copyleft"
+restrictions. LuaEclipse qualifies as Open Source software. Its licenses are
+compatible with GPL. LuaEclipse is not in the public domain and the Kepler
+Project keep its copyright. The legal details are below.
+
+The spirit of the license is that you are free to use LuaEclipse for any
+purpose at no cost without having to ask us. The only requirement is that if
+you do use LuaEclipse, then you should give us credit by including the
+appropriate copyright notice somewhere in your product or its documentation.
+
+The LuaEclipse library is designed and implemented by the Kepler Project team.
+The implementation is not derived from licensed software.
+
+-------------------------------------------------------------------------------
+
+Copyright © 2003-2007 The Kepler Project.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bd84cbbdb87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Diego Martin Nieto Cid <dnietoc at gmail dot com>
+
+pkgname=eclipse-luaeclipse
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Eclipse plugin for the development of applications in the Lua programming language."
+arch=('i686' 'x86_64')
+url="http://luaeclipse.luaforge.net/"
+license=('BSD')
+depends=('eclipse')
+source=(
+ 'http://luaforge.net/frs/download.php/3193/luaeclipse-1.2.0.zip'
+ 'LICENSE'
+ )
+md5sums=('f735a47b31186aac90aca30e485d00f5'
+ '84e13cfae8aac2d34107f67fbec06ca7')
+
+package() {
+ _dest=${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+
+ cd ${srcdir}
+
+ # Features
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+
+ # Plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
+
+ install -Dm644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+