summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2019-10-06 01:33:55 +0200
committerRaimar Bühmann2019-10-06 01:33:55 +0200
commitc60876ab449c26acc9a205bdc6dc35fd8cb0f292 (patch)
tree3f18de1a5c44768c6f368e2e29e7d975c80404fa
downloadaur-c60876ab449c26acc9a205bdc6dc35fd8cb0f292.tar.gz
init with version 2.2.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31076f4f7cb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = eclipse-m2t-xpand
+ pkgdesc = Model to Text Xpand for Eclipse IDE
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = https://projects.eclipse.org/projects/modeling.m2t.xpand
+ arch = any
+ license = EPL
+ makedepends = java-environment-common
+ depends = eclipse-orbit-com-google-inject
+ options = !strip
+ source = https://download.eclipse.org//modeling/m2t/xpand/downloads/drops/2.2.0/R201605260315/m2t-xpand-Update-2.2.0.zip
+ sha256sums = 90a217c3231dbcab6773cb0470557c7ae760d73b15a3c430895cdebf79bacf08
+
+pkgname = eclipse-m2t-xpand
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fa097f544265
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+eclipse-*-any.pkg.tar.xz
+m2t-xpand-*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8ddf8ddb112
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Raimar Buehmann <raimar at buehmann dot de>
+
+pkgname=eclipse-m2t-xpand
+pkgver=2.2.0
+_buildtime=R201605260315
+pkgrel=1
+pkgdesc='Model to Text Xpand for Eclipse IDE'
+url="https://projects.eclipse.org/projects/modeling.m2t.xpand"
+arch=('any')
+license=('EPL')
+depends=('eclipse-orbit-com-google-inject')
+makedepends=('java-environment-common')
+options=(!strip)
+# https://download.eclipse.org//modeling/m2t/xpand/downloads/drops/2.2.0/R201605260315/m2t-xpand-Update-2.2.0.zip
+source=(
+ https://download.eclipse.org//modeling/m2t/xpand/downloads/drops/${pkgver}/${_buildtime}/m2t-xpand-Update-${pkgver}.zip
+)
+sha256sums=('90a217c3231dbcab6773cb0470557c7ae760d73b15a3c430895cdebf79bacf08')
+
+package() {
+ _dest=${pkgdir}/usr/lib/eclipse/dropins/${pkgname/eclipse-}/eclipse
+ install -d $_dest
+ # remove feature sources
+ rm features/*source_*
+ # extract features (otherwise features are not recognized)
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+ # copy plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
+}